animatedbubblebottomnav 0.0.3
animatedbubblebottomnav: ^0.0.3 copied to clipboard

Animated Bubble Bottom Navigation

3
likes
60/ 130
pub points
45%
popularity

We analyzed this package on Sep 22, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 61 API elements (3.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

lib/Utils/constants.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/animatedbubblebottomnav.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
license^1.0.01.0.11.0.1
like_button^1.0.11.0.42.0.3
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-26.0.026.0.0
analyzer-2.3.02.3.0
args-2.3.02.3.0
async-2.8.22.8.2
boolean_selector-2.1.02.1.0
characters-1.1.01.2.0
charcode-1.3.11.3.1
cli_util-0.3.30.3.3
collection-1.15.01.15.0
convert-3.0.13.0.1
coverage-1.0.31.0.3
crypto-3.0.13.0.1
file-6.1.26.1.2
frontend_server_client-2.1.22.1.2
glob-2.0.12.0.1
guard-1.0.41.0.4
http_multi_server-3.0.13.0.1
http_parser-4.0.04.0.0
intl-0.16.10.17.0
io-1.0.31.0.3
js-0.6.30.6.3
l_cli-1.0.21.0.2
logging-1.0.21.0.2
matcher-0.12.110.12.11
meta-1.7.01.7.0
mime-1.0.01.0.0
node_preamble-2.0.12.0.1
package_config-2.0.22.0.2
path-1.8.01.8.0
pedantic-1.11.11.11.1
pool-1.5.01.5.0
pub_semver-2.1.02.1.0
shelf-1.2.01.2.0
shelf_packages_handler-3.0.03.0.0
shelf_static-1.1.01.1.0
shelf_web_socket-1.0.11.0.1
sky_engine-0.0.990.0.99
source_map_stack_trace-2.1.02.1.0
source_maps-0.10.100.10.10
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
test-1.17.121.17.12
test_api-0.4.30.4.3
test_core-0.4.20.4.2
tmpl-1.0.11.0.1
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
vm_service-7.3.07.3.0
watcher-1.0.01.0.0
web_socket_channel-2.1.02.1.0
webkit_inspection_protocol-1.0.01.0.0
yaml-3.1.03.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.1` on like_button does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions like_button to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.1+1, Flutter 2.5.0, Dart 2.14.0.