animated_overflow 1.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 77

animated_overflow #

Cosmos Software

Pub License

A simple widget for animating overflowing content horizontally or vertically with fade.

Media | Description | How-to-Use

Media #

Watch on Youtube:

v1.0.0



Description #

This is a simple widget for animating overflowing content horizontally or vertically with fade.

How-to-Use #

Simply create an AnimatedOverflow as shown in the example:

AnimatedOverflow({
    Key key,
    animatedOverflowDirection,
    child,
    maxHeight,
    maxWidth,
    padding : 0.0,
    speed   : 50})

Further Explanations:

For a complete set of descriptions for all parameters and methods, see the documentation.

  • The [animatedOverflowDirection] and [child] can't be null.
  • The [maxHeight] is only considered if [animatedOverflowDirection] is [AnimatedOverflowDirection.VERTICAL] and it should not be null.
  • The [maxWidth] is only considered if [animatedOverflowDirection] is [AnimatedOverflowDirection.HORIZONTAL] and it should not be null.

Notes #

Any help, suggestion or criticism is appreciated!

Cheers.





[1.0.0] - 27.11.2019

  • Initial release.

example/README.md

example #

Example project for animated_overflow.

animated_overflow #

Cosmos Software

Pub License

A simple widget for animating overflowing content horizontally or vertically with fade.

Media | Description | How-to-Use

Media #

Watch on Youtube:

v1.0.0



Description #

This is a simple widget for animating overflowing content horizontally or vertically with fade.

How-to-Use #

Simply create an AnimatedOverflow as shown in the example:

AnimatedOverflow({
    Key key,
    animatedOverflowDirection,
    child,
    maxHeight,
    maxWidth,
    padding : 0.0,
    speed   : 50})

Further Explanations:

For a complete set of descriptions for all parameters and methods, see the documentation.

  • The [animatedOverflowDirection] and [child] can't be null.
  • The [maxHeight] is only considered if [animatedOverflowDirection] is [AnimatedOverflowDirection.VERTICAL] and it should not be null.
  • The [maxWidth] is only considered if [animatedOverflowDirection] is [AnimatedOverflowDirection.HORIZONTAL] and it should not be null.

Notes #

Any help, suggestion or criticism is appreciated!

Cheers.





Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  animated_overflow: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:animated_overflow/animated_overflow.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
54
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
77
Learn more about scoring.

We analyzed this package on Jan 16, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health suggestions

Format lib/animated_overflow.dart.

Run flutter format to format lib/animated_overflow.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.2 <3.0.0
flutter 0.0.0
simple_animations ^1.3.4 1.3.4
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test