angular_youtube_iframe 0.1.3+1

  • Readme
  • Changelog
  • Installing
  • 0

angular_youtube_iframe #

A Youtube player component for AngularDart (4+) based on Youtube iFrame interop


Try the demo

<youtube-iframe [playerId]="'ytvideo'" [videoId]="videoId"
                [start]="videoStart" [end]="videoEnd"
                [width]="width" [height]="height"

Changelog #

0.1.3 #

  • components : PlayerToolbar & PlayerProgressBar
  • new player @Input : blockVideoInteraction, showRelated, playlist, list, listType...

0.1.2 #

  • fix the events callbacks

0.1.1 #

  • new @Inputs : mobilePlaysInline, modestBranding, start, end,...
  • add a currentState property
  • updated example

0.1.0 #

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  angular_youtube_iframe: ^0.1.3+1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:angular_youtube_iframe/angular_youtube_iframe.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.0 <2.0.0