angular_fire 0.2.1


An unofficial library for AngularDart and Firebase.

pub package Build Status

Install #

The current stable release of angular_fire works best with the following:

  angular2: ^3.1.0
  angular_fire: ^0.1.0
  firebase: ^3.1.0

To get started, you need to, at minimum, include the Firebase SDK:

  <script src=""></script>

Usage #

Services #

FirebaseAuth #

A high-level authentication service. First setup for dependency injection:

import 'package:angular2/angular2.dart';
import 'package:angular2/platform/browser.dart';
import 'package:angular_fire/angular_fire.dart';
import 'package:firebase/firebase.dart' as sdk;

main() {
  bootstrap(AngularFireExample, <dynamic>[
      useValue: new FirebaseAuth(
          apiKey: '...',
          authDomain: '...',
          databaseURL: '...',
          storageBucket: '...',

Then inject into your app and use. See GoogleSignInComponent below for an example.

Components #

GoogleSignInComponent #

Displays a rendered sign in box for Google authentication that follows the branding guidelines.

import 'package:angular2/angular2.dart';
import 'package:angular_fire/angular_fire.dart';

  selector: 'angular-fire-example',
  directives: const [
  template: r'''
    <google-sign-in (trigger)="signIn()">
class AngularFireExample {
  final FirebaseAuth _auth;
  void onTrigger() {

NOTE: To use this component, you must have the brand assets in your web/assets directory, or use the [assetPath] property, or the googleSignInAssetPath token at bootstrap time to configure the location of your assets - for example on an external CDN.

IfFirebaseAuthDirective #

Like ngIf, but shows content if the value matches the current authentication:

<div *ifFirebaseAuth="true; let currentUser = currentUser">
  Logged in as: {{currentUser.displayName}}.
  <button (click)="signOut()">Sign Out</button>

<div *ifFirebaseAuth="false">
  Waiting for sign in...



Contributing #

We welcome a diverse set of contributions, including, but not limited to:

For the stability of the API and existing users, consider opening an issue first before implementing a large new feature or breaking an API. For smaller changes (like documentation, bug fixes), just send a pull request.

Testing #

Run the (simple) test suite in Dartium. It doesn't currently run on Travis:

$ pub run angular_test -p dartium

0.2.1 #

  • Add an option to add additional authorization scopes to googleSignIn:
// Authenticate and allow read-only access to Google Calendar.
final user = await firebaseAuth.googleSignIn(
  scopes: [

if (user != null) {
  // You have access!

0.2.0 #

  • Fixed a bug that flashed signed off content before loading.
  • Changed the default behavior of Google sign-in to prompt for account:
abstract class FirebaseAuth {
  Future<FirebaseUser> googleSignIn({bool prompt: true});

0.1.1 #

  • Removed a print statement that was always occurring.
  • Added a high-level FirebaseAuth class, and Google sign-in.
  • Added IfFirebaseAuthDirective.

0.1.0 #

  • Initial commit of GoogleSignInComppnent.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  angular_fire: ^0.2.1

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:angular_fire/angular_fire.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.22.0 <2.0.0