angular_analyzer_plugin 0.0.17+6

AngularDart analyzer plugin #

A plugin for the Dart analyzer library package providing AngularDart support.

Features and bugs #

Please file feature requests and bugs at the issue tracker.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  angular_analyzer_plugin: ^0.0.17+6

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:angular_analyzer_plugin/angular_analyzer_plugin.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
95
Health:
Code health derived from static analysis. [more]
75
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
19
Overall:
Weighted score of the above. [more]
74
Learn more about scoring.

We analyzed this package on Apr 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6

Health suggestions

Fix lib/errors.dart. (-25 points)

Analysis of lib/errors.dart reported 72 hints, including:

line 7 col 35: Avoid const keyword.

line 54 col 22: 'CONTENT_OR_VIEW_CHILDREN_REQUIRES_QUERY_LIST' is deprecated and shouldn't be used.

line 84 col 28: Unnecessary new keyword.

line 98 col 44: Avoid const keyword.

line 124 col 44: Avoid const keyword.

Fix lib/src/angular_driver.dart. (-25 points)

Analysis of lib/src/angular_driver.dart reported 112 hints, including:

line 52 col 23: Unnecessary new keyword.

line 53 col 22: Unnecessary new keyword.

line 54 col 25: Unnecessary new keyword.

line 57 col 27: Unnecessary new keyword.

line 58 col 31: Unnecessary new keyword.

Fix lib/src/completion.dart. (-25 points)

Analysis of lib/src/completion.dart reported 68 hints, including:

line 47 col 31: Unnecessary new keyword.

line 106 col 7: Unnecessary new keyword.

line 127 col 11: Unnecessary new keyword.

line 198 col 35: Unnecessary new keyword.

line 202 col 29: Unnecessary new keyword.

Fix additional 20 files with analysis or formatting issues. (-172.92 points)

Additional issues in the following files:

  • lib/src/directive_linking.dart (64 hints)
  • lib/src/resolver.dart (103 hints)
  • lib/src/summary/format.dart (178 hints)
  • lib/src/converter.dart (42 hints)
  • lib/src/selector.dart (27 hints)
  • lib/plugin.dart (25 hints)
  • lib/src/directive_extraction.dart (21 hints)
  • lib/src/view_extraction.dart (16 hints)
  • lib/src/standard_components.dart (15 hints)
  • lib/src/file_tracker.dart (9 hints)
  • lib/src/model.dart (9 hints)
  • lib/ast.dart (8 hints)
  • lib/src/options.dart (8 hints)
  • lib/src/completion_request.dart (7 hints)
  • lib/src/navigation.dart (7 hints)
  • lib/src/tasks.dart (5 hints)
  • lib/src/ng_expr_parser.dart (2 hints)
  • lib/src/pipe_extraction.dart (2 hints)
  • lib/starter.dart (2 hints)
  • lib/src/strings.dart (1 hint)

Maintenance issues and suggestions

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Support latest dependencies. (-20 points)

The version constraint in pubspec.yaml does not support the latest published versions for 2 dependencies (analyzer, analyzer_plugin).

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and angular_analyzer_plugin.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Package is getting outdated. (-0.82 points)

The package was last published 52 weeks ago.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.0.0 <3.0.0
analyzer 0.34.2 0.34.2 0.39.6
analyzer_plugin 0.0.1-alpha.6 0.0.1-alpha.6 0.2.1
angular_ast ^0.5.0 0.5.8 0.5.11
crypto >=1.1.1 <3.0.0 2.1.4
meta ^1.0.2 1.1.8
plugin ^0.2.0 0.2.0+3
yaml ^2.1.2 2.2.0
Transitive dependencies
args 1.6.0
async 2.4.1
charcode 1.1.3
collection 1.14.12
convert 2.1.1
csslib 0.15.0 0.16.1
front_end 0.1.9 0.1.29
glob 1.2.0
html 0.13.4+2 0.14.0+3
js 0.6.1+1
kernel 0.3.9 0.3.29
node_interop 1.0.3
node_io 1.0.1+2
package_config 1.9.3
path 1.6.4
pedantic 1.9.0
pub_semver 1.4.4
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
utf 0.9.0+5
watcher 0.9.7+14
Dev dependencies
mockito ^3.0.0
test ^1.2.0
test_reflective_loader ^0.1.0