angular 5.0.0-alpha+5
angular: ^5.0.0-alpha+5 copied to clipboard

outdated Dart 2 incompatible

Fast and productive web framework


Pub Package Build Status Gitter

AngularDart is a productive web application framework that powers some of Google's most critical applications. It's built on Dart and used extensively by Google AdWords, AdSense, Fiber, and many more projects.

Built with AngularDart

NOTE: As of angular 5.0.0-alpha+1 dependency_overrides are required:

  analyzer: ^0.31.0-alpha.1

This is because we are starting to use and support the Dart 2.0.0 SDK, which is evolving. We expect to no longer require overrides once we are at a beta release, but this is unlikely until sometime in early 2018.

New to AngularDart? #

Ramp up quickly with our docs, codelabs, and examples:

You may also be interested in other codelabs and a set of community contributed tutorials.

Getting AngularDart #

AngularDart is available as the angular package on pub.

For historical reasons, this package was once called angular2. We have since dropped the 2 and are now just angular. If you're looking for version 2.x or 3.x, see the angular2 package.

Resources #