angel_sembast 1.0.1
angel_sembast: ^1.0.1 copied to clipboard

Dart native
Flutter Android iOS Linux macOS Windows

package:sembast-powered CRUD services for the Angel framework.

0
likes
70 / 100
pub points
0 %
popularity

We analyzed this package on Mar 3, 2021, and awarded it 70 pub points (of a possible 100):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 10

10/10 points: Package has an example

  • Found example at: example/main.dart
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:angel_sembast/angel_sembast.dart that imports:
  • package:angel_framework/angel_framework.dart that imports:
  • package:angel_framework/src/core/core.dart that imports:
  • package:angel_framework/src/core/service.dart that imports:
  • package:angel_framework/src/core/server.dart that imports:
  • package:angel_framework/src/core/routable.dart that imports:
  • package:angel_framework/src/core/response_context.dart that imports:
  • package:angel_framework/src/core/request_context.dart that imports:
  • package:http_server/http_server.dart that imports:
  • package:http_server/src/http_multipart_form_data.dart that imports:
  • package:http_server/src/http_multipart_form_data_impl.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 17 issues. Showing the first 2:

INFO: Unnecessary new keyword.

lib/angel_sembast.dart:24:14

   ╷
24 │     params = new Map<String, dynamic>.from(params ?? {});
   │              ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/angel_sembast.dart

INFO: Unnecessary new keyword.

lib/angel_sembast.dart:39:20

   ╷
39 │           sort.add(new SortOrder(v.toString(), true));
   │                    ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/angel_sembast.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angel_framework^2.0.0-alpha2.1.12.1.1
sembast^1.9.51.17.2+23.0.0+1
Transitive dependencies
PackageConstraintCompatibleLatest
angel_container-1.1.01.1.0
angel_model-1.0.31.0.3
angel_route-3.1.0+13.1.0+1
charcode-1.2.01.2.0
clock-1.1.01.1.0
code_buffer-1.0.11.0.1
collection-1.15.01.15.0
combinator-1.1.01.1.0
convert-2.1.13.0.0
crypto-2.1.53.0.0
dart2_constant-1.0.2+dart21.0.2+dart2
file-5.2.16.1.0
http2-1.0.12.0.0
http_parser-3.1.44.0.0
http_server-0.9.8+30.9.8+3
intl-0.17.00.17.0
matcher-0.12.100.12.10
merge_map-1.0.21.0.2
meta-1.3.01.3.0
mime-0.9.71.0.0
mock_request-1.0.71.0.7
path-1.8.01.8.0
quiver-2.1.53.0.0
quiver_hashcode-2.0.02.0.0
recase-2.0.13.0.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
synchronized-3.0.03.0.0
term_glyph-1.2.01.2.0
tuple-1.0.31.0.3
typed_data-1.3.01.3.0
uuid-2.2.23.0.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.9.5` on sembast does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions sembast to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.2, Dart 2.12.0.

0
likes
70
pub points
0%
popularity

Publisher

angel-dart.dev

package:sembast-powered CRUD services for the Angel framework.

Repository (GitHub)
View/report issues

License

MIT (LICENSE)

Dependencies

angel_framework, sembast

More

Packages that depend on angel_sembast