angel_migration_runner 2.0.0

Dart native js
Flutter Android iOS web

Command-line based database migration runner for Angel's ORM.

0
likes
80 / 110
pub points
55 %
popularity

We analyzed this package on Sep 25, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 47 API elements (2.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 30 issues. Showing the first 2:

INFO: Unnecessary new keyword.

lib/src/cli.dart:7:13

  ╷
7 │   var cmd = new CommandRunner('migration_runner', 'Executes Angel migrations.')
  │             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/cli.dart

INFO: Unnecessary new keyword.

lib/src/cli.dart:8:18

  ╷
8 │     ..addCommand(new _UpCommand(migrationRunner))
  │                  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/cli.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angel_migration^2.0.0-alpha2.0.02.0.0
angel_orm^2.0.0-dev.22.0.22.0.2
args^1.0.01.6.01.6.0
charcode^1.0.01.1.31.1.3
postgres>=0.9.5 <2.0.01.0.22.2.0
Transitive dependencies
PackageConstraintCompatibleLatest
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
intl-0.15.80.16.1
meta-1.2.31.2.3
path-1.7.01.7.0
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `>=0.9.5 <2.0.0` on postgres does not support the latest published version `2.2.0`

pubspec.yaml:13:13

   ╷
13 │   postgres: ">=0.9.5 <2.0.0"
   │             ^^^^^^^^^^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
80
pub points
55%
popularity

Command-line based database migration runner for Angel's ORM.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

thosakwe@gmail.com

License

MIT (LICENSE)

Dependencies

angel_migration, angel_orm, args, charcode, postgres

More

Packages that depend on angel_migration_runner