angel_migration 2.0.0

Dart native js
Flutter Android iOS web

Database migration runtime for Angel's ORM. Use this package to define schemas.

0
likes
80 / 110
pub points
74 %
popularity

We analyzed this package on Sep 25, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 55 API elements (3.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 10 issues. Showing the first 2:

INFO: Unnecessary new keyword.

lib/src/column.dart:18:7

   ╷
18 │       new List<MigrationColumnReference>.unmodifiable(_references);
   │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/column.dart

INFO: Use `=` to separate a named parameter from its default value.

lib/src/column.dart:21:23

   ╷
21 │       {bool isNullable: true, int length, IndexType indexType, defaultValue})
   │                       ^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/column.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angel_orm^2.0.0-dev2.0.22.0.2
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
collection-1.14.131.14.13
intl-0.15.80.16.1
meta-1.2.31.2.3
path-1.7.01.7.0
source_span-1.7.01.7.0
string_scanner-1.0.51.0.5
term_glyph-1.1.01.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
80
pub points
74%
popularity

Database migration runtime for Angel's ORM. Use this package to define schemas.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

thosakwe@gmail.com

License

MIT (LICENSE)

Dependencies

angel_orm

More

Packages that depend on angel_migration