angel_hot 2.0.6
angel_hot: ^2.0.6 copied to clipboard

Supports hot reloading/hot code push of Angel servers on file changes.

4
likes
80 / 110
pub points
63 %
popularity

We analyzed this package on Apr 17, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 9 out of 13 API elements (69.2 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:angel_hot/angel_hot.dart that imports:
  • package:watcher/watcher.dart that imports:
  • package:watcher/src/file_watcher/polling.dart that imports:
  • package:watcher/src/stat.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 12 issues. Showing the first 2:

INFO: DO use curly braces for all flow control structures.

lib/angel_hot.dart:107:7

    ╷
107 │       response.write(_renderer.render(doc));
    │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/angel_hot.dart

INFO: DO use curly braces for all flow control structures.

lib/angel_hot.dart:117:7

    ╷
117 │       return await _handle(request);
    │       ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/angel_hot.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angel_framework^2.0.0-alpha2.1.12.1.1
angel_websocket^2.0.0-alpha2.0.32.0.3
charcode^1.0.01.2.01.2.0
glob^1.0.01.2.02.0.1
html_builder^1.0.01.0.51.0.5
io^0.3.20.3.51.0.0
path^1.0.01.8.01.8.0
vm_service_lib^0.3.50.3.10+23.22.2+1
watcher^0.9.00.9.7+151.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
angel_auth-2.1.5+12.1.5+1
angel_client-2.0.22.0.2
angel_container-1.1.01.1.0
angel_http_exception-1.1.01.1.0
angel_model-1.0.31.0.3
angel_route-3.1.0+13.1.0+1
async-2.5.02.5.0
clock-1.1.01.1.0
code_buffer-1.0.11.0.1
collection-1.15.01.15.0
combinator-1.1.01.1.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
dart2_constant-1.0.2+dart21.0.2+dart2
file-5.2.16.1.0
http2-1.0.12.0.0
http_parser-3.1.44.0.0
http_server-0.9.8+31.0.0
intl-0.17.00.17.0
js-0.6.30.6.3
json_god-2.0.0-beta+32.0.0-beta+3
matcher-0.12.100.12.10
merge_map-1.0.21.0.2
meta-1.3.01.3.0
mime-0.9.71.0.0
mock_request-1.0.71.0.7
node_interop-1.2.12.0.0
node_io-1.2.01.2.0
quiver-2.1.53.0.1
quiver_hashcode-2.0.03.0.0+1
recase-2.0.13.0.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
tuple-1.0.32.0.0
typed_data-1.3.01.3.0
uuid-2.2.23.0.4
web_socket_channel-1.2.02.0.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `^1.0.0` on glob does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions glob to update the constraint.

The constraint `^0.3.2` on io does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions io to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

4
likes
80
pub points
63%
popularity

Publisher

angel-dart.dev

Supports hot reloading/hot code push of Angel servers on file changes.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

angel_framework, angel_websocket, charcode, glob, html_builder, io, path, vm_service_lib, watcher

More

Packages that depend on angel_hot