angel_firestore 0.1.3
angel_firestore: ^0.1.3 copied to clipboard

Dart native
Flutter Android iOS

Admin Firebase firestore service for the angel framework. With this package you can use firestore as a DB in your angel project.

0
likes
90 / 110
pub points
0 %
popularity

We analyzed this package on Feb 24, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 10 out of 31 API elements (32.3 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:angel_firestore/angel_firestore.dart that imports:
  • package:angel_firestore/firestore_service.dart that imports:
  • package:dartbase_admin/dartbase_admin.dart that imports:
  • package:dartbase_admin/firestore/models.dart that imports:
  • package:dartbase_admin/firestore/firestore_gateway.dart that imports:
  • package:grpc/grpc.dart that imports:
  • package:grpc/src/shared/streams.dart that imports:
  • package:http2/transport.dart that imports:
  • package:http2/src/hpack/hpack.dart that imports:
  • package:http2/src/hpack/huffman_table.dart that imports:
  • package:http2/src/hpack/huffman.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angel_framework^2.1.12.1.12.1.1
dartbase_admin^0.1.30.1.40.1.4
http^0.12.10.12.20.13.0
Transitive dependencies
PackageConstraintCompatibleLatest
_discoveryapis_commons-0.2.10.2.1
angel_http_exception-1.1.01.1.0
angel_model-1.0.31.0.3
angel_route-3.1.0+13.1.0+1
archive-2.0.133.0.0
args-1.6.02.0.0
asn1lib-0.6.50.8.1
async-2.5.02.5.0
built_collection-4.3.25.0.0
built_value-7.1.08.0.0
charcode-1.2.01.2.0
clock-1.1.01.1.0
code_buffer-1.0.11.0.1
collection-1.15.01.15.0
combinator-1.1.01.1.0
convert-2.1.13.0.0
corsac_jwt-0.2.20.4.0
crypto-2.1.53.0.0
crypto_keys-0.1.30.1.4
dart2_constant-1.0.2+dart21.0.2+dart2
file-5.2.16.1.0
fixnum-0.10.111.0.0
gcloud-0.7.30.7.3
googleapis-0.56.11.0.0
googleapis_auth-0.2.12+11.0.0
grpc-2.9.03.0.0
http2-1.0.12.0.0
http_parser-3.1.44.0.0
http_server-0.9.8+30.9.8+3
intl-0.17.00.17.0
jose-0.1.2+10.2.2
json_annotation-3.1.14.0.0
logging-0.11.41.0.0
matcher-0.12.100.12.10
merge_map-1.0.21.0.2
meta-1.3.01.3.0
mime-0.9.71.0.0
mock_request-1.0.71.0.7
openid_client-0.2.50.3.1
path-1.8.01.8.0
pointycastle-1.0.22.0.1
protobuf-1.1.22.0.0
quiver-2.1.53.0.0
quiver_hashcode-2.0.02.0.0
recase-2.0.13.0.1
rsa_pkcs-1.1.31.1.4
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
tuple-1.0.31.0.3
typed_data-1.3.01.3.0
uuid-2.2.23.0.0
x509-0.1.30.1.4

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.12.1` on http does not support the latest published version `0.13.0`

pubspec.yaml:13:9

   ╷
13 │   http: ^0.12.1
   │         ^^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Dart 2.12.0-133.2.beta.

0
likes
90
pub points
0%
popularity

Admin Firebase firestore service for the angel framework. With this package you can use firestore as a DB in your angel project.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

netantho@gmail.com

License

MIT (LICENSE)

Dependencies

angel_framework, dartbase_admin, http

More

Packages that depend on angel_firestore