angel_container_generator 1.0.1
angel_container_generator: ^1.0.1 copied to clipboard

Codegen support for using pkg:reflectable with pkg:angel_container.

0
likes
70 / 110
pub points
12 %
popularity

We analyzed this package on Apr 22, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 12 API elements (16.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 22 issues. Showing the first 2:

INFO: Avoid const keyword.

lib/angel_container_generator.dart:5:31

  ╷
5 │ const Reflectable contained = const ContainedReflectable();
  │                               ^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/angel_container_generator.dart

INFO: Unnecessary new keyword.

lib/angel_container_generator.dart:41:13

   ╷
41 │       throw new UnsupportedError('Cannot reflect $function.');
   │             ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/angel_container_generator.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angel_container^1.0.0-alpha1.1.01.1.0
reflectable^2.0.02.2.93.0.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-14.0.021.0.0
analyzer-0.41.11.5.0
args-1.6.02.0.0
async-2.5.02.5.0
build-1.6.22.0.1
build_config-0.4.51.0.0
build_daemon-2.1.103.0.0
build_resolvers-1.5.32.0.1
build_runner_core-6.1.77.0.0
built_collection-5.0.05.0.0
built_value-8.0.48.0.4
charcode-1.2.01.2.0
checked_yaml-1.0.42.0.1
cli_util-0.2.00.3.0
clock-1.1.01.1.0
code_builder-3.7.04.0.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
dart_style-1.3.122.0.0
file-5.2.16.1.0
fixnum-1.0.01.0.0
glob-1.2.02.0.1
graphs-0.2.02.0.0
http_multi_server-2.2.03.0.1
http_parser-4.0.04.0.0
intl-0.17.00.17.0
io-0.3.51.0.0
js-0.6.30.6.3
json_annotation-4.0.14.0.1
logging-0.11.41.0.1
matcher-0.12.100.12.10
meta-1.3.01.3.0
mime-1.0.01.0.0
node_interop-1.2.12.0.1
node_io-1.2.01.2.0
package_config-1.9.32.0.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
pool-1.5.01.5.0
pub_semver-1.4.42.0.0
pubspec_parse-0.1.81.0.0
quiver-2.1.53.0.1
shelf-1.1.01.1.0
shelf_web_socket-0.2.4+11.0.1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
stream_transform-2.0.02.0.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
timing-0.1.1+31.0.0
typed_data-1.3.01.3.0
watcher-0.9.7+151.0.0
web_socket_channel-1.2.02.0.0
yaml-3.1.03.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.0` on reflectable does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions reflectable to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

0
likes
70
pub points
12%
popularity

Codegen support for using pkg:reflectable with pkg:angel_container.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

thosakwe@gmail.com

License

MIT (LICENSE)

Dependencies

angel_container, reflectable

More

Packages that depend on angel_container_generator