angel_configuration 2.2.0
angel_configuration: ^2.2.0 copied to clipboard

Dart native
Flutter Android iOS

Automatic YAML application configuration loader for Angel, with .env support.

0
likes
90 / 110
pub points
67 %
popularity

We analyzed this package on Feb 25, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 5 API elements (40.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:angel_configuration/angel_configuration.dart that imports:
  • package:file/file.dart that imports:
  • package:file/src/interface.dart that imports:
  • package:file/src/io.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
angel_framework^2.0.02.1.12.1.1
dotenv^1.0.01.0.02.0.0
file^5.0.05.2.16.1.0
merge_map^1.0.01.0.21.0.2
yaml^2.0.02.2.13.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
angel_container-1.1.01.1.0
angel_http_exception-1.1.01.1.0
angel_model-1.0.31.0.3
angel_route-3.1.0+13.1.0+1
args-1.6.02.0.0
charcode-1.1.31.2.0
code_buffer-1.0.11.0.1
collection-1.14.131.15.0
combinator-1.1.01.1.0
convert-2.1.13.0.0
crypto-2.1.53.0.0
dart2_constant-1.0.2+dart21.0.2+dart2
http2-1.0.12.0.0
http_parser-3.1.44.0.0
http_server-0.9.8+30.9.8+3
intl-0.16.10.17.0
matcher-0.12.90.12.10
meta-1.2.41.3.0
mime-0.9.71.0.0
mock_request-1.0.71.0.7
path-1.7.01.8.0
quiver-2.1.53.0.0
quiver_hashcode-2.0.02.0.0
recase-2.0.13.0.1
source_span-1.7.01.8.1
stack_trace-1.9.61.10.0
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
tuple-1.0.31.0.3
typed_data-1.2.01.3.0
uuid-2.2.23.0.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^1.0.0` on dotenv does not support the latest published version `2.0.0`

pubspec.yaml:10:11

   ╷
10 │   dotenv: ^1.0.0
   │           ^^^^^^
   ╵
The constraint `^5.0.0` on file does not support the latest published version `6.1.0`

pubspec.yaml:11:9

   ╷
11 │   file: ^5.0.0
   │         ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.14.10, Dart 2.10.5.

0
likes
90
pub points
67%
popularity

Publisher

angel-dart.dev

Automatic YAML application configuration loader for Angel, with .env support.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

angel_framework, dotenv, file, merge_map, yaml

More

Packages that depend on angel_configuration