analyzer_plugin 0.6.0
analyzer_plugin: ^0.6.0 copied to clipboard

A framework and support code for building plugins for the analysis server.

15
likes
90 / 130
pub points
95 %
popularity

We analyzed this package on May 7, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 1299 out of 1898 API elements (68.4 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:analyzer_plugin/plugin/assist_mixin.dart that imports:
  • package:analyzer_plugin/utilities/assist/assist.dart that imports:
  • package:analyzer_plugin/src/utilities/assist/assist.dart that imports:
  • package:analyzer/file_system/file_system.dart that imports:
  • package:analyzer/src/file_system/file_system.dart that imports:
  • package:analyzer/src/generated/source.dart that imports:
  • package:analyzer/src/generated/sdk.dart that imports:
  • package:analyzer/dart/ast/visitor.dart that imports:
  • package:analyzer/dart/ast/ast.dart that imports:
  • package:analyzer/src/generated/utilities_dart.dart that imports:
  • package:analyzer/src/dart/element/element.dart that imports:
  • package:analyzer/src/summary2/reference.dart that imports:
  • package:analyzer/dart/element/element.dart that imports:
  • package:analyzer/src/generated/engine.dart that imports:
  • package:analyzer/error/listener.dart that imports:
  • package:analyzer/error/error.dart that imports:
  • package:analyzer/src/generated/parser.dart that imports:
  • package:analyzer/src/fasta/ast_builder.dart that imports:
  • package:analyzer/src/dart/ast/ast_factory.dart that imports:
  • package:analyzer/src/dart/ast/ast.dart that imports:
  • package:analyzer/src/summary2/linked_unit_context.dart that imports:
  • package:analyzer/src/summary2/linked_library_context.dart that imports:
  • package:analyzer/src/summary2/linked_element_factory.dart that imports:
  • package:analyzer/src/summary2/bundle_reader.dart that imports:
  • package:analyzer/src/summary2/ast_binary_reader.dart that imports:
  • package:analyzer/src/generated/testing/ast_test_factory.dart that imports:
  • package:analyzer/src/dart/element/type.dart that imports:
  • package:analyzer/src/dart/element/member.dart that imports:
  • package:analyzer/dart/analysis/session.dart that imports:
  • package:analyzer/dart/analysis/analysis_context.dart that imports:
  • package:analyzer/src/workspace/workspace.dart that imports:
  • package:analyzer/src/workspace/bazel.dart that imports:
  • package:analyzer/src/workspace/bazel_watcher.dart that imports:
  • package:watcher/watcher.dart that imports:
  • package:watcher/src/file_watcher/polling.dart that imports:
  • package:watcher/src/stat.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: 'getResult' is deprecated and shouldn't be used. Use getResult2() instead.

lib/plugin/plugin.dart:164:31

    ╷
164 │     var result = await driver.getResult(path);
    │                               ^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/plugin/plugin.dart

INFO: 'getResolvedUnit' is deprecated and shouldn't be used. Use getResolvedUnit2() instead.

lib/src/utilities/change_builder/change_builder_core.dart:196:33

    ╷
196 │     var result = await session?.getResolvedUnit(path);
    │                                 ^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/utilities/change_builder/change_builder_core.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

  • Could not run dart pub outdated: dart pub get failed:
Because analyzer_plugin depends on analyzer_utilities from path which doesn't exist (could not find package analyzer_utilities at "../analyzer_utilities"), version solving failed.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.16.0, Dart 2.12.4.