analyzer 0.25.1-alpha.1
analyzer: ^0.25.1-alpha.1 copied to clipboard

outdated Dart 2 incompatible

Static analyzer for Dart.

0.25.0 #

  • Commandline interface moved to dedicated analyzer_cli package. Files moved:
    • bin/analyzer.dart
    • lib/options.dart
    • lib/src/analyzer_impl.dart
    • lib/src/error_formatter.dart
  • Removed dependency on the args package.

0.22.1 #

  • Changes in the async/await support.

0.22.0 #

New API:

  • Source.uri added.

    Breaking changes:

  • DartSdk.fromEncoding replaced with fromFileUri.

  • Source.resolveRelative replaced with resolveRelativeUri.

69
likes
0
pub points
99%
popularity

Publisher

tools.dart.dev

Static analyzer for Dart.

Homepage

License

LICENSE

Dependencies

args, path, plugin, watcher

More

Packages that depend on analyzer