analysis_utils 0.1.1
analysis_utils: ^0.1.1 copied to clipboard

Utilities for simplifying static source code analysis

0
likes
65/ 130
pub points
0%
popularity

We analyzed this package on Oct 26, 2021, and awarded it 65 pub points (of a possible 130):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:28:49

   ╷
28 │ <p>Please file feature requests and bugs at the <a href="http://github.com/Rodsevich/analysis_utils/issues/">issue tracker</a>.</p>
   │                                                 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/analysis_utils_example.dart

0/10 points: Failed to run dartdoc

  • dartdoc failed with:
exitCode: 255
stdout: [2021-10-23T11:11:52.357194] Starting...
Documenting analysis_utils...
Initialized dartdoc with 616 libraries in 53.7 seconds
Generating docs for library analyzer_primitives from package:analysis_utils/analyzer_components.dart...
Generating docs for library analysis_utils.analysis from package:analysis_utils/analysis.dart...
Generating docs for library element_analysis from package:analysis_utils/element_analysis.dart...
Generating docs for library analysis_utils.analysis from package:analysis_utils/annotation.dart...
Documented 4 public libraries in 1.0 seconds

stderr:   error: failed to write file at: analysis_utils.analysis/analysis_utils.analysis-library.html
    for symbol analysis_utils.analysis: (file:///tmp/pub-dartlang-dartdocGKJCPK/pkg/lib/annotation.dart:2:9)
    conflicting with file already generated by analysis_utils.analysis: (file:///tmp/pub-dartlang-dartdocGKJCPK/pkg/lib/analysis.dart:2:9)
            Dartdoc generates a path and filename to write to for each symbol.
            analysis_utils.analysis conflicts with another symbol in the generated path, and
            therefore can not be written out.  Changing the name, library name, or
            class name (if appropriate) of one of the conflicting items can resolve
            the conflict.   Alternatively, use the @nodoc tag in one symbol's
            documentation comments to hide it.
Found 0 warnings and 1 error.
Unhandled exception:
encountered 1 errors
#0      Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:241:9)
<asynchronous suspension>
#1      main (file:///project/pkg/pub_dartdoc/bin/pub_dartdoc.dart:33:19)
<asynchronous suspension>


Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:analysis_utils/analysis.dart that imports:
  • package:analysis_utils/src/analysis.dart that imports:
  • package:analyzer/dart/ast/visitor.dart that imports:
  • package:analyzer/dart/ast/ast.dart that imports:
  • package:analyzer/src/generated/utilities_dart.dart that imports:
  • package:analyzer/src/dart/element/element.dart that imports:
  • package:analyzer/src/summary2/reference.dart that imports:
  • package:analyzer/dart/element/element.dart that imports:
  • package:analyzer/src/task/api/model.dart that imports:
  • package:analyzer/src/generated/source.dart that imports:
  • package:analyzer/src/generated/source_io.dart that imports:
  • package:analyzer/src/generated/java_io.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.39.100.39.172.7.0
cli_util^0.1.3+20.1.40.3.5
glob^1.1.71.2.02.0.2
path^1.6.21.8.01.8.0
source_span^1.4.01.8.11.8.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.030.0.0
args-1.6.02.3.0
async-2.8.22.8.2
charcode-1.3.11.3.1
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
csslib-0.16.20.17.1
file-5.2.16.1.2
html-0.14.0+40.15.0
intl-0.17.00.17.0
js-0.6.30.6.3
meta-1.7.01.7.0
node_interop-1.2.12.1.0
node_io-1.2.02.1.0
package_config-1.9.32.0.2
pedantic-1.11.11.11.1
pub_semver-1.4.42.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-0.9.7+151.0.1
yaml-2.2.13.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.39.10` on analyzer does not support the stable version `0.40.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^0.1.3+2` on cli_util does not support the stable version `0.2.0`.

Try running dart pub upgrade --major-versions cli_util to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.5.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Dart 2.14.3.

0
likes
65
pub points
0%
popularity

Utilities for simplifying static source code analysis

Homepage

License

BSD-3-Clause (LICENSE)

Dependencies

analyzer, cli_util, glob, path, source_span

More

Packages that depend on analysis_utils