ampos_ui_library 0.0.30

ampos_ui_library #

A new Flutter project.

Getting Started #

To use this library, add ampos_ui_library as a dependency in your pubspec.yaml file.

dependencies:
 ampos_ui_library: "^0.0.30"
TextWidget(
  fontSize: FontSize.normal,
  fontWeight: FontWeight.w300,
  color: AmposColors.outerSpace
);

TextWidget default value: Font size: 16
Font weight: FontWeight.w300
Text color: AmposColors.outerSpace

[0.0.30] - 12 July 2019

  • Add transparent colors.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  ampos_ui_library: ^0.0.30

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:ampos_ui_library/ampos_ui_library.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
66
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
79
Learn more about scoring.

We analyzed this package on Jul 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-0.38 points)

1105 out of 1129 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/chart/progress_bar/arc_painter.dart.

Run flutter format to format lib/chart/progress_bar/arc_painter.dart.

Format lib/widgets/base_button.dart.

Run flutter format to format lib/widgets/base_button.dart.

Format lib/widgets/button.dart.

Run flutter format to format lib/widgets/button.dart.

Fix additional 3 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/widgets/edit_text.dart (Run flutter format to format lib/widgets/edit_text.dart.)
  • lib/widgets/section_header.dart (Run flutter format to format lib/widgets/section_header.dart.)
  • lib/widgets/text_widget.dart (Run flutter format to format lib/widgets/text_widget.dart.)

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and ampos_ui_library.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.2 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test

Admin