amplify_api_plugin_interface 0.2.10 icon indicating copy to clipboard operation
amplify_api_plugin_interface: ^0.2.10 copied to clipboard

The platform interface for the API module of Amplify Flutter.

0
likes
120/ 130
pub points
90%
popularity

We analyzed this package 6 hours ago, and awarded it 120 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 47 out of 96 API elements (49.0 %) have documentation comments.
icon indicating section status
Platform Support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:amplify_api_plugin_interface/amplify_api_plugin_interface.dart that imports:
  • package:amplify_api_plugin_interface/src/types.dart that imports:
  • package:amplify_api_plugin_interface/src/graphql/graphql_request.dart that imports:
  • package:amplify_core/types/uuid.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:amplify_api_plugin_interface/amplify_api_plugin_interface.dart that imports:
  • package:amplify_api_plugin_interface/src/types.dart that imports:
  • package:amplify_api_plugin_interface/src/graphql/graphql_request.dart that imports:
  • package:amplify_core/types/uuid.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:amplify_api_plugin_interface/amplify_api_plugin_interface.dart that imports:
  • package:amplify_api_plugin_interface/src/types.dart that imports:
  • package:amplify_api_plugin_interface/src/graphql/graphql_request.dart that imports:
  • package:amplify_core/types/uuid.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:amplify_api_plugin_interface/amplify_api_plugin_interface.dart that imports:
  • package:amplify_api_plugin_interface/src/types.dart that imports:
  • package:amplify_api_plugin_interface/src/graphql/graphql_request.dart that imports:
  • package:amplify_core/types/uuid.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
30 / 30icon to trigger folding of the section

30/30 points: code has no errors, warnings, lints, or formatting issues

icon indicating section status
Support up-to-date dependencies
20 / 20icon to trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
amplify_core0.2.100.2.100.2.10
collection^1.15.01.15.01.15.0
flutterflutter0.0.00.0.0
meta^1.3.01.7.01.7.0
uuid^3.0.13.0.53.0.5
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.01.2.0
crypto-3.0.13.0.1
plugin_platform_interface-2.1.22.1.2
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.12.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.5, Flutter 2.8.1, Dart 2.15.1.

0
likes
120
pub points
90%
popularity

Publisher

shield icon for verified publishersaws-amplify.com

The platform interface for the API module of Amplify Flutter.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

Dependencies

amplify_core, collection, flutter, meta, uuid

More

Packages that depend on amplify_api_plugin_interface