amplify_analytics_plugin_interface 0.1.0
amplify_analytics_plugin_interface: ^0.1.0 copied to clipboard

Flutter Android iOS

The platform interface for the analytics module of Amplify Flutter.

0
likes
70 / 110
pub points
94 %
popularity

We analyzed this package on Mar 3, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 54 API elements (5.6 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:amplify_analytics_plugin_interface/amplify_analytics_plugin_interface.dart that imports:
  • package:amplify_analytics_plugin_interface/src/types.dart that imports:
  • package:amplify_analytics_plugin_interface/src/Exceptions/AnalyticsException.dart that imports:
  • package:amplify_core/types/exception/AmplifyException.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/src/Analytics/AnalyticsEvent.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/Analytics/AnalyticsProperties.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
amplify_core0.1.00.1.00.1.0
flutterflutter0.0.00.0.0
meta^1.1.81.3.01.3.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
plugin_platform_interface-1.0.32.0.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.3, Flutter 2.0.0, Dart 2.12.0.

0
likes
70
pub points
94%
popularity

Publisher

aws-amplify.com

The platform interface for the analytics module of Amplify Flutter.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

amplify_core, flutter, meta

More

Packages that depend on amplify_analytics_plugin_interface