amity_video_player 0.0.3 copy "amity_video_player: ^0.0.3" to clipboard
amity_video_player: ^0.0.3 copied to clipboard

A Supporting library to Amity Could SDK that provide the amity_video_player for playing recorded and live stream

0
likes
80/ 140
pub points
70%
popularity

We analyzed this package 4 days ago, and awarded it 80 pub points (of a possible 140):

failed
Follow Dart file conventions
10 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

  • pubspec.yaml doesn't have a homepage entry.
  • pubspec.yaml doesn't have a repository entry.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

2 out of 32 API elements (6.3 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: amity_player_client, amity_player_client.StreamPlayerClient, amity_player_client.StreamPlayerClient.StreamPlayerClient, amity_player_client.StreamPlayerClient.getFunction, amity_player_client.StreamPlayerClient.setup.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:amity_video_player/amity_video_player.dart that imports:
  • package:amity_video_player/core/presentation/amity_video_player.dart that imports:
  • package:flutter_vlc_player/flutter_vlc_player.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:amity_video_player/amity_video_player.dart that imports:
  • package:amity_video_player/core/presentation/amity_video_player.dart that imports:
  • package:flutter_vlc_player/flutter_vlc_player.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:amity_video_player/amity_video_player.dart that imports:
  • package:amity_video_player/core/presentation/amity_video_player.dart that imports:
  • package:flutter_vlc_player/flutter_vlc_player.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:amity_video_player/amity_video_player.dart that imports:
  • package:amity_video_player/core/presentation/amity_video_player.dart that imports:
  • package:flutter_vlc_player/flutter_vlc_player.dart that declares support for platforms: Android, iOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 9 issues. Showing the first 2:

WARNING: The value of the field '_showOverLay' isn't used.

lib/core/presentation/amity_video_player.dart:42:8

   ╷
42 │   bool _showOverLay = false;
   │        ^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/core/presentation/amity_video_player.dart

WARNING: The value of the field '_replayButtonIconSize' isn't used.

lib/core/presentation/video_overlay.dart:6:23

  ╷
6 │   static const double _replayButtonIconSize = 20;
  │                       ^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/core/presentation/video_overlay.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
amity_sdk_api ^0.0.3 0.0.3 0.0.3
flutter flutter 0.0.0 0.0.0
flutter_vlc_player ^7.4.1 7.4.1 7.4.1
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
flutter_vlc_player_platform_interface - 2.0.3 2.0.3
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

0
likes
80
pub points
70%
popularity

Publisher

verified publisheramity.co

A Supporting library to Amity Could SDK that provide the amity_video_player for playing recorded and live stream

Documentation

API reference

License

unknown (LICENSE)

Dependencies

amity_sdk_api, flutter, flutter_vlc_player

More

Packages that depend on amity_video_player