amity_sdk_api 0.0.3 copy "amity_sdk_api: ^0.0.3" to clipboard
amity_sdk_api: ^0.0.3 copied to clipboard

A Supporting api to enable user add more supporting features to Amity Cloud SDK

0
likes
90/ 140
pub points
31%
popularity

We analyzed this package 3 days ago, and awarded it 90 pub points (of a possible 140):

failed
Follow Dart file conventions
10 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

  • pubspec.yaml doesn't have a homepage entry.
  • pubspec.yaml doesn't have a repository entry.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

0 out of 17 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: amity_client_configuration, amity_client_configuration.AmityClientConfiguration, amity_client_configuration.AmityClientConfiguration.AmityClientConfiguration, amity_client_configuration.AmityClientConfiguration.streamFunctionInterface, amity_sdk_api.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/stream/amity_client_configuration.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/stream/interfaces/stream_function_interface.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

0
likes
90
pub points
31%
popularity

Publisher

verified publisheramity.co

A Supporting api to enable user add more supporting features to Amity Cloud SDK

Documentation

API reference

License

unknown (LICENSE)

Dependencies

flutter

More

Packages that depend on amity_sdk_api