amap_search_fluttify 0.16.2 icon indicating copy to clipboard operation
amap_search_fluttify: ^0.16.2 copied to clipboard

An `Amap` Search Component, Powered By `Fluttify` Engine, A Dart Bindings Generator for Native SDK.

5
likes
75/ 130
pub points
83%
popularity

We analyzed this package 2 days ago, and awarded it 75 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
15 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

0/10 points: 20% or more of the public API has dartdoc comments

  • 556 out of 6933 API elements (8.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:amap_search_fluttify/amap_search_fluttify.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:amap_search_fluttify/amap_search_fluttify.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:amap_search_fluttify/amap_search_fluttify.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:amap_search_fluttify/amap_search_fluttify.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 788 issues. Showing the first 2:

INFO: The import of 'package:foundation_fluttify/foundation_fluttify.dart' is unnecessary because all of the used elements are also provided by the import of 'package:amap_search_fluttify/src/android/android.export.g.dart'.

lib/src/android/com/amap/api/services/busline/BusLineItem.g.dart:12:8

   ╷
12 │ import 'package:foundation_fluttify/foundation_fluttify.dart';
   │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/android/com/amap/api/services/busline/BusLineItem.g.dart

INFO: The import of 'package:core_location_fluttify/core_location_fluttify.dart' is unnecessary because all of the used elements are also provided by the import of 'package:amap_search_fluttify/src/android/android.export.g.dart'.

lib/src/android/com/amap/api/services/busline/BusLineItem.g.dart:13:8

   ╷
13 │ import 'package:core_location_fluttify/core_location_fluttify.dart';
   │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/android/com/amap/api/services/busline/BusLineItem.g.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
amap_core_fluttify^0.14.00.14.00.14.0
core_location_fluttify^0.6.00.6.00.7.1
flutterflutter0.0.00.0.0
foundation_fluttify^0.11.10.11.10.13.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.01.2.1
collection-1.16.01.16.0
material_color_utilities-0.1.40.1.5
meta-1.7.01.8.0
sky_engine-0.0.990.0.99
vector_math-2.1.22.1.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.6.0` on core_location_fluttify does not support the stable version `0.7.1`, that was published 23 days ago.

When core_location_fluttify is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions core_location_fluttify to update the constraint.

The constraint `^0.11.1` on foundation_fluttify does not support the stable version `0.12.1`.

Try running dart pub upgrade --major-versions foundation_fluttify to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.6.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.13, Flutter 3.0.3, Dart 2.17.5.

5
likes
75
pub points
83%
popularity

Publisher

verified publisher iconfluttify.com

An `Amap` Search Component, Powered By `Fluttify` Engine, A Dart Bindings Generator for Native SDK.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Icon for licenses.unknown (LICENSE)

Dependencies

amap_core_fluttify, core_location_fluttify, flutter, foundation_fluttify

More

Packages that depend on amap_search_fluttify