amap_location_muka 0.1.2
amap_location_muka: ^0.1.2 copied to clipboard

Flutter高德定位插件

0
likes
110/ 130
pub points
19%
popularity

We analyzed this package on Oct 16, 2021, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

The package description contains too many non-ASCII characters.

The site uses English as its primary language. The content of the description field in your package's pubspec.yaml should primarily contain characters used in English.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 29 out of 46 API elements (63.0 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Found 4 issues. Showing the first 2:

Consider supporting these prerelease platforms:

Package does not support Flutter platform `Windows`.

Because:

  • package:amap_location_muka/amap_location_muka.dart that declares support for platforms: Android, iOS, Web.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/amap_location_muka.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/amap_location_muka_web.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
amap_core^1.0.11.0.21.0.2
flutterflutter0.0.00.0.0
flutter_web_pluginsflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
js-0.6.30.6.3
meta-1.7.01.7.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.