amap_flutter_map 3.0.0 copy "amap_flutter_map: ^3.0.0" to clipboard
amap_flutter_map: ^3.0.0 copied to clipboard

高德地图SDK Flutter插件

62
likes
125/ 160
pub points
94%
popularity

We analyzed this package 2 days ago, and awarded it 125 pub points (of a possible 160):

failed
Follow Dart file conventions
15 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

The package description contains too many non-ASCII characters.

The site uses English as its primary language. The content of the description field in your package's pubspec.yaml should primarily contain characters used in English.

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

179 out of 205 API elements (87.3 %) have documentation comments.

Some symbols that are missing documentation: amap_flutter_map.AMapController.disponse, amap_flutter_map.AMapController.mapId, amap_flutter_map.AMapWidget.createState, amap_flutter_map.BaseOverlay.clone, amap_flutter_map.BaseOverlay.id.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:amap_flutter_map/amap_flutter_map.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:amap_flutter_map/amap_flutter_map.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:amap_flutter_map/amap_flutter_map.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:amap_flutter_map/amap_flutter_map.dart that declares support for platforms: Android, iOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 41 issues. Showing the first 2:

WARNING: The parameter type of '==' operators should be non-nullable.

lib/src/types/camera.dart:58:17

   ╷
58 │   bool operator ==(dynamic other) {
   │                 ^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/types/camera.dart

WARNING: Duplicate import.

lib/src/types/marker.dart:9:8

  ╷
9 │ import 'base_overlay.dart';
  │        ^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/types/marker.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
amap_flutter_base ^3.0.0 3.0.0 3.0.0
flutter flutter 0.0.0 0.0.0
flutter_plugin_android_lifecycle ^2.0.1 2.0.20 2.0.20
meta ^1.3.0 1.12.0 1.15.0
plugin_platform_interface ^2.0.0 2.1.8 2.1.8
stream_transform ^2.0.0 2.1.0 2.1.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.