amap_core_fluttify 0.12.0 icon indicating copy to clipboard operation
amap_core_fluttify: ^0.12.0 copied to clipboard

An `Amap` Core Component, Powered By `Fluttify` Engine, A Dart Bindings Generator For Native SDK.

1
likes
65/ 130
pub points
84%
popularity

We analyzed this package 8 days ago, and awarded it 65 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
15 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

`README.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of README.md in your package should primarily contain characters used in English.

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
10 / 20icon to trigger folding of the section

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 8 out of 178 API elements (4.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Support multiple platforms
10 / 20icon to trigger folding of the section

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:amap_core_fluttify/amap_core_fluttify.dart that declares support for platforms: Android, iOS.
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 14 issues. Showing the first 2:

lib/src/android/constants.g.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/android/type_op.g.dart doesn't match the Dart formatter.

To format your files run: flutter format .

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
core_location_fluttify^0.4.00.4.10.6.0
flutterflutter0.0.00.0.0
foundation_fluttify^0.9.00.9.10+10.12.1+1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.01.2.0
collection-1.15.01.15.0
meta-1.7.01.7.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.12.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.4.0` on core_location_fluttify does not support the stable version `0.5.0`.

Try running dart pub upgrade --major-versions core_location_fluttify to update the constraint.

The constraint `^0.9.0` on foundation_fluttify does not support the stable version `0.10.0`.

Try running dart pub upgrade --major-versions foundation_fluttify to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.6.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.8.1, Dart 2.15.1.

1
likes
65
pub points
84%
popularity

Publisher

shield icon for verified publishersfluttify.com

An `Amap` Core Component, Powered By `Fluttify` Engine, A Dart Bindings Generator For Native SDK.

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

core_location_fluttify, flutter, foundation_fluttify

More

Packages that depend on amap_core_fluttify