alps_rfid_n6737 1.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • new58

alps_rfid_n6737 #

A new flutter plugin project. alps_rfid_n6737: ^0.0.1 https://pub.dev/packages/alps_rfid_n6737

Getting Started #

import 'package:alps_rfid_n6737/alps_rfid_n6737.dart';

Start reading RFID tags #

AlpsRfidN6737.startRead();

Setting RSSI Level #

Min Level is 50 and Max is 90

AlpsRfidN6737.setPowerLevel(level: 60);

Keep always reading RFID tags #

AlpsRfidN6737.continuousRead();

Listen to RFID tags #

AlpsRfidN6737.dataStream.receiveBroadcastStream().listen(rfidBoarding);    void rfidBoarding(dynamic rfidId) { }

Close RFID Sensor #

AlpsRfidN6737.stopRead();

Read One RFID tag #

AlpsRfidN6737.readOne();

1.0.0 #

  • Update docs.

0.0.2 #

  • Update docs.

0.0.1 #

  • Initial release.

example/README.md

alps_rfid_n6737_example #

alps_rfid_n6737 #

A new flutter plugin project. alps_rfid_n6737: ^0.0.1 https://pub.dev/packages/alps_rfid_n6737

Getting Started #

import 'package:alps_rfid_n6737/alps_rfid_n6737.dart';

Start reading RFID tags #

AlpsRfidN6737.startRead();

Setting RSSI Level #

Min Level is 50 and Max is 90

AlpsRfidN6737.setPowerLevel(level: 60);

Keep always reading RFID tags #

AlpsRfidN6737.continuousRead();

Listen to RFID tags #

AlpsRfidN6737.dataStream.receiveBroadcastStream().listen(rfidBoarding);    void rfidBoarding(dynamic rfidId) { }

Close RFID Sensor #

AlpsRfidN6737.stopRead();

Read One RFID tag #

AlpsRfidN6737.readOne();

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  alps_rfid_n6737: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:alps_rfid_n6737/alps_rfid_n6737.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
17
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
58
Learn more about scoring.

We analyzed this package on Oct 9, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test