alpha_vantage_package 1.0.0 icon indicating copy to clipboard operation
alpha_vantage_package: ^1.0.0 copied to clipboard

alpha vantage package api updated by Basil Zuberi, initial creation by Jose Melendez Castro <melendezcastro@gmail.com> <https://github.com/jcmelend/flutter_alpha_vantage_api>

4
likes
70/ 130
pub points
41%
popularity

We analyzed this package 4 days ago, and awarded it 70 pub points (of a possible 130):

icon indicating section status
Follow Dart file conventions
20 / 20icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

icon indicating section status
Provide documentation
0 / 20icon to trigger folding of the section

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 0 out of 76 API elements (0.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 28 issues. Showing the first 2:

INFO: Name non-constant identifiers using lowerCamelCase.

lib/src/CryptoCurrencies.dart:9:10

  ╷
9 │   String _INTRADAY = "DIGITAL_CURRENCY_INTRADAY";
  │          ^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/CryptoCurrencies.dart

INFO: Name non-constant identifiers using lowerCamelCase.

lib/src/CryptoCurrencies.dart:10:10

   ╷
10 │   String _DAILY = "DIGITAL_CURRENCY_DAILY";
   │          ^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/CryptoCurrencies.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
http^0.12.0+40.12.20.13.4
test^1.9.41.16.51.21.3
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-22.0.041.0.0
analyzer-1.7.24.2.0
args-2.3.12.3.1
async-2.9.02.9.0
boolean_selector-2.1.02.1.0
characters-1.2.01.2.1
charcode-1.3.11.3.1
cli_util-0.3.50.3.5
collection-1.16.01.16.0
convert-3.0.23.0.2
coverage-1.0.31.5.0
crypto-3.0.23.0.2
file-6.1.26.1.2
glob-2.1.02.1.0
http_multi_server-3.2.13.2.1
http_parser-3.1.44.0.1
io-1.0.31.0.3
js-0.6.40.6.4
logging-1.0.21.0.2
matcher-0.12.100.12.12
material_color_utilities-0.1.40.1.5
meta-1.7.01.8.0
mime-1.0.01.0.2
node_preamble-1.4.132.0.1
package_config-2.1.02.1.0
path-1.8.21.8.2
pedantic-1.11.11.11.1
pool-1.5.11.5.1
pub_semver-2.1.12.1.1
shelf-0.7.91.3.1
shelf_packages_handler-2.0.13.0.1
shelf_static-0.2.9+21.1.1
shelf_web_socket-0.2.4+11.0.2
sky_engine-0.0.990.0.99
source_map_stack_trace-2.1.02.1.0
source_maps-0.10.100.10.10
source_span-1.9.01.9.0
stack_trace-1.10.01.10.0
stream_channel-2.1.02.1.0
string_scanner-1.1.11.1.1
term_glyph-1.2.11.2.1
test_api-0.2.190.4.11
test_core-0.3.150.4.15
typed_data-1.3.11.3.1
vector_math-2.1.22.1.2
vm_service-6.2.09.0.0
watcher-1.0.11.0.1
web_socket_channel-2.2.02.2.0
webkit_inspection_protocol-1.1.01.1.0
yaml-3.1.13.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.12.0+4` on http does not support the stable version `0.13.0`.

Try running dart pub upgrade --major-versions http to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
0 / 20icon to trigger folding of the section

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.13, Flutter 3.0.3, Dart 2.17.5.

4
likes
70
pub points
41%
popularity

Publisher

unverified uploader

alpha vantage package api updated by Basil Zuberi, initial creation by Jose Melendez Castro <melendezcastro@gmail.com> <https://github.com/jcmelend/flutter_alpha_vantage_api>

Homepage

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

flutter, http, test

More

Packages that depend on alpha_vantage_package