alipay_kit 6.0.0 copy "alipay_kit: ^6.0.0" to clipboard
alipay_kit: ^6.0.0 copied to clipboard

A powerful Flutter plugin allowing developers to auth/pay with natvie Android & iOS Alipay SDKs.

alipay_kit #

Pub Package License

Flutter 版支付宝SDK

相关工具 #

Dart/Flutter Pub 私服 #

相关文档 #

开始使用 #

Android #

# 不需要做任何额外接入工作
# 混淆已打入 Library,随 Library 引用,自动添加到 apk 打包混淆

iOS #

# 不需要做任何额外接入工作
# 配置已集成到脚本里
  • UTDID冲突的问题解决方案
alipay_kit:
+  ios: noutdid # 默认 utdid

Flutter #

  • 配置
dependencies:
  alipay_kit: ^${latestTag} # 默认不包含iOS支付
#  alipay_kit_ios: ^${latestTag} # iOS支付

alipay_kit:
#  ios: noutdid # 默认 utdid
  scheme: ${your alipay scheme} # scheme 不能为纯数字,推荐:alipay${appId}
  • 安装(仅iOS)
# step.1 安装必要依赖
sudo gem install plist
# step.2 切换工作目录,插件里为 example/ios/,普通项目为 ios/
cd example/ios/
# step.3 执行脚本
pod install

示例 #

示例

Star History #

stars

32
likes
160
pub points
94%
popularity

Publisher

verified publisherrxreader.com

A powerful Flutter plugin allowing developers to auth/pay with natvie Android & iOS Alipay SDKs.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (license)

Dependencies

alipay_kit_android, flutter, json_annotation, plugin_platform_interface

More

Packages that depend on alipay_kit