alan_voice 2.0.7

  • Readme
  • Changelog
  • Installing
  • 81

alan_voice #

Alan voice plugin

About #

This plugin helps you to integrate Alan voice experience into your Flutter app

Quickstart #

Add Alan Voice dependency to your app

your pubspec.yaml file:

dependencies:
  flutter:
    sdk: flutter
    ...
    
  alan_voice: 2.0.7

First add alan_voice package dependency

import 'package:alan_voice/alan_voice.dart';

Add Alan button to your main widget

AlanVoice.addButton(
        "8e0b083e795c924d64635bba9c3571f42e956eca572e1d8b807a3e2338fdd0dc/stage",
        buttonAlign: AlanVoice.BUTTON_ALIGN_LEFT);
  1. That's it. Now run your app and press the button!

See this page for more info.

2.0.7 #

Add isActive API

2.0.6 #

Add error handling for visual states

2.0.5 #

Update no connection state for button

2.0.4 #

Fixed defaults

2.0.3 #

Updated documentation page

2.0.2 #

Added support for authentication params

2.0.0 #

Added iOS support

1.3.0 #

AndroidX Support

1.2.2 #

Updated description

1.2.1 #

Add description and link to the docs section

1.2.0 #

Added wakeword model auto update Added s2t panel option studio support

1.1.0 #

Add wakeword option

1.0.2 #

Add support for multiple endpoints

1.0.1 #

Fix entities coloring in the STT panel

1.0.0 #

Add connection state callbacks

0.9.0 #

Button colors can now be customized from the Alan tutor project page

0.8.5 #

Added animations to color transitions

0.8.4 #

Add coloring to STT panel

0.8.3 #

Fix button turn off

0.8.2 #

Enable|disable STT panel switch

0.8.1 #

Fix button clickthrough

0.8.0 #

Alan button drag&drop support

0.7.0 #

Add STT panel

0.6.7 #

Fix Alan hint tappable space

0.6.6 #

Add init overloads

0.6.5 #

Fix QR code recognition

0.6.4 #

Additional logging

Added Alan hint

0.6.3 #

  • Fix docs

0.6.2 #

  • Add QR callback

0.6.0 #

  • Added commands callbacks

0.5.0 #

  • Initial release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  alan_voice: ^2.0.7

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:alan_voice/alan_voice.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
66
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
81
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:alan_voice/alan_voice.dart] that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because of import path [package:alan_voice/alan_voice.dart] that declares support for platforms: android, ios

Package does not support Flutter platform web

Because of import path [package:alan_voice/alan_voice.dart] that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because of import path [package:alan_voice/alan_voice.dart] that declares support for platforms: android, ios

Package not compatible with SDK dart

because of import path [alan_voice] that is in a package requiring null.

Health suggestions

Format lib/alan_voice.dart.

Run flutter format to format lib/alan_voice.dart.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and alan_voice.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
package_info ^0.4.0+14 0.4.1
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test