ajustee_client 1.0.2
ajustee_client: ^1.0.2 copied to clipboard

Dart native
Flutter Android iOS Linux macOS Windows

Ajustee client. Ajustee – a revolutionary solution that is about to transform the way your team changes, manages and tracks software configurations.

0
likes
80 / 110
pub points
0 %
popularity

We analyzed this package on Mar 4, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 131 API elements (1.5 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:ajustee_client/ajustee_client.dart that imports:
  • package:ajustee_client/services/socket_provider.dart that imports:
  • package:ajustee_client/services/socket_client.dart that imports:
  • package:web_socket_channel/io.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/models/configuration_key.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/util/type_conversion.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
http^0.12.0+40.12.20.13.0
intl^0.16.10.16.10.17.0
meta^1.1.81.3.01.3.0
web_socket_channel^1.1.01.2.02.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
async-2.5.02.5.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
crypto-3.0.03.0.0
http_parser-3.1.44.0.0
path-1.8.01.8.0
pedantic-1.11.01.11.0
source_span-1.8.11.8.1
stream_channel-2.1.02.1.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^0.12.0+4` on http does not support the stable version `0.13.0`, that was published 26 days ago.

When http is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions http to update the constraint.

The constraint `^0.16.1` on intl does not support the stable version `0.17.0`, that was published 28 days ago.

When intl is 30 days old, this package will no longer be awarded points in this category.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.3, Dart 2.12.0.

0
likes
80
pub points
0%
popularity

Publisher

ajustee.com

Ajustee client. Ajustee – a revolutionary solution that is about to transform the way your team changes, manages and tracks software configurations.

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

http, intl, meta, web_socket_channel

More

Packages that depend on ajustee_client