ai 0.1.10

Library that help construct neural networks (AI) with Dart.

1
likes
50 / 110
pub points
23 %
popularity

We analyzed this package on Oct 31, 2020, and awarded it 50 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 91 out of 99 API elements (91.9 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:ai/ai.dart that imports:
  • package:ai/src/network/mlp.dart that imports:
  • package:ai/src/network/network_base.dart that imports:
  • package:ai/src/layer.dart that imports:
  • package:ai/src/memory/short_memory.dart that imports:
  • package:ai/src/memory/long_memory.dart that imports:
  • package:ai/src/utils/system.dart that imports:
  • dart:io
Pass static analysis
0 / 30

0/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

ERROR: Too many positional arguments: 3 expected, but 4 found.

lib/src/network/cnn.dart:19:37

   ╷
19 │       final newImage = Image.fromBytes(originalImage.width, originalImage.height,
   │ ┌─────────────────────────────────────^
20 │ │         imageRGB.toList().map((v) => v.toInt()).toList(), Image.RGB);
   │ └────────────────────────────────────────────────────────────────────^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/network/cnn.dart

ERROR: The getter 'RGB' isn't defined for the type 'Image'.

lib/src/network/cnn.dart:20:65

   ╷
20 │         imageRGB.toList().map((v) => v.toInt()).toList(), Image.RGB);
   │                                                                 ^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/network/cnn.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
extended_math^0.0.260.0.29+10.0.29+1
image^2.0.72.1.182.1.18
json_annotation^2.0.02.4.03.1.0
meta^1.1.61.2.31.2.3
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.132.0.13
args-1.6.01.6.0
charcode-1.1.31.1.3
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
matcher-0.12.90.12.9
path-1.7.01.7.0
petitparser-3.1.03.1.0
quiver-2.1.4+12.1.4+1
stack_trace-1.9.51.9.5
typed_data-1.2.01.2.0
xml-4.5.14.5.1

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.0` on json_annotation does not support the latest published version `3.1.0`

pubspec.yaml:14:20

   ╷
14 │   json_annotation: ^2.0.0
   │                    ^^^^^^
   ╵

10/10 points: Package supports latest stable Dart and Flutter SDKs

1
likes
50
pub points
23%
popularity

Library that help construct neural networks (AI) with Dart.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

zhenja.96.lemok@gmail.com

License

MIT (LICENSE)

Dependencies

extended_math, image, json_annotation, meta

More

Packages that depend on ai