aes256gcm 1.0.1 copy "aes256gcm: ^1.0.1" to clipboard
aes256gcm: ^1.0.1 copied to clipboard

AES-256-GCM symmetric encryption functions that allow to encrypt/decrypt package

6
likes
120/ 140
pub points
73%
popularity

We analyzed this package 21 hours ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

4 out of 12 API elements (33.3 %) have documentation comments.

Some symbols that are missing documentation: aes256gcm, aes256gcm.Aes256Gcm, aes256gcm.Aes256Gcm.Aes256Gcm, aes256gcm.IV_LENGTH, aes256gcm.KEY_ITERATIONS_COUNT.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

INFO: The variable name 'KEY_LENGTH' isn't a lowerCamelCase identifier.

lib/aes256gcm.dart:7:11

  ╷
7 │ final int KEY_LENGTH = 32;
  │           ^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/aes256gcm.dart

INFO: The variable name 'IV_LENGTH' isn't a lowerCamelCase identifier.

lib/aes256gcm.dart:8:11

  ╷
8 │ final int IV_LENGTH = 12;
  │           ^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run dart analyze lib/aes256gcm.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
convert ^3.0.1 3.1.1 3.1.1
cryptography ^2.0.5 2.7.0 2.7.0
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.18.0 1.18.0
crypto - 3.0.3 3.0.3
ffi - 2.1.2 2.1.2
js - 0.6.7 0.7.1
meta - 1.15.0 1.15.0
typed_data - 1.3.2 1.3.2

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.1.

Check the analysis log for details.

6
likes
120
pub points
73%
popularity

Publisher

verified publishergetswifty.pro

AES-256-GCM symmetric encryption functions that allow to encrypt/decrypt package

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

convert, cryptography

More

Packages that depend on aes256gcm