advanced_page_slider 0.1.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 70

AdvancedPagerSlider-Flutter #

An Advanced version of Flutter [PageView] github-link with more extra awesome widgets.

Usage #

import 'package:advanced_page_slider/advanced_page_slider.dart';
import 'package:flutter/material.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Advanced PageView Sample App',
      theme: ThemeData(
        primarySwatch: Colors.blue,
      ),
      home: MyHomePage(title: 'Advanced PageView Demo Home Page'),
    );
  }
}

class MyHomePage extends StatefulWidget {
  MyHomePage({Key key, this.title}) : super(key: key);

  final String title;

  @override
  _MyHomePageState createState() => _MyHomePageState();
}

class _MyHomePageState extends State<MyHomePage> {
  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text(widget.title),
      ),
      body: PageSlider(
        //height: MediaQuery.of(context).size.height / 2,
        initialPage: 0,
        hidePaginationIndexer: false,
        disableSWiping: false,
        hideSliderIndicator: false,
        sliderIndicatorPosition: SliderIndicatorPosition.BOTTOM,
        overlaySliderIndicator: true,
        onPageChanged: (page) => print("page $page"),
        reverse: false,
        scrollDirection: Axis.horizontal,
        widgets: [
          Container(
            child: Center(
              child: Text("text 1"),
            ),
          ),
          Container(
            child: Center(
              child: Text("text 2"),
            ),
          ),
          Container(
            child: Center(
              child: Text("text 3"),
            ),
          ),
        ],
      ),
    );
  }
}

License #

MIT

0.0.1 #

  • Initial version.

0.0.2 #

  • added CHANGELOG.md file.

0.0.3 #

  • added README.md file.

0.0.4 #

  • added README.md file.

0.1.0 #

  • updated README.md file.

example/main.dart

import 'package:advanced_page_slider/advanced_page_slider.dart';
import 'package:flutter/material.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Advanced PageView Sample App',
      theme: ThemeData(
        primarySwatch: Colors.blue,
      ),
      home: MyHomePage(title: 'Advanced PageView Demo Home Page'),
    );
  }
}

class MyHomePage extends StatefulWidget {
  MyHomePage({Key key, this.title}) : super(key: key);

  final String title;

  @override
  _MyHomePageState createState() => _MyHomePageState();
}

class _MyHomePageState extends State<MyHomePage> {
  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text(widget.title),
      ),
      body: PageSlider(
        //height: MediaQuery.of(context).size.height / 2,
        initialPage: 0,
        hidePaginationIndexer: false,
        disableSWiping: false,
        hideSliderIndicator: false,
        sliderIndicatorPosition: SliderIndicatorPosition.BOTTOM,
        overlaySliderIndicator: true,
        onPageChanged: (page) => print("page $page"),
        reverse: false,
        scrollDirection: Axis.horizontal,
        widgets: [
          Container(
            child: Center(
              child: Text("text 1"),
            ),
          ),
          Container(
            child: Center(
              child: Text("text 2"),
            ),
          ),
          Container(
            child: Center(
              child: Text("text 3"),
            ),
          ),
        ],
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  advanced_page_slider: ^0.1.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:advanced_page_slider/advanced_page_slider.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
40
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
70
Learn more about scoring.

We analyzed this package on Dec 6, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/advanced_page_slider.dart.

Run flutter format to format lib/advanced_page_slider.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
cupertino_icons ^0.1.2 0.1.3
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test