adeptarch 1.0.3+6

adeptarch #

Adept Arch lib

Getting Started #

This project is a starting point for a Dart package, a library module containing code that can be shared easily across multiple Flutter or Dart projects.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

[1.0.3+6]

[1.0.2+5]

[1.0.1]

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  adeptarch: ^1.0.3+6

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:adeptarch/adeptarch.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
42
Health:
Code health derived from static analysis. [more]
96
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
62
Learn more about scoring.

We analyzed this package on Feb 24, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.7

Health suggestions

Fix lib/src/widgets/date_filter_view.dart. (-1 points)

Analysis of lib/src/widgets/date_filter_view.dart reported 2 hints:

line 13 col 7: This class (or a class which this class inherits from) is marked as '@immutable', but one or more of its instance fields are not final: DateFilterView.textDateStart, DateFilterView.textDateEnd, DateFilterView.textAll, DateFilterView.textFromYesterday, DateFilterView.textFromToday, DateFilterView.textFromNow, DateFilterView.textFromTomorrow, DateFilterView.textBeforeToday, DateFilterView.textAfterToday, DateFilterView.textInARange, DateFilterView.datePickerMode, BaseFilterView.filterController, BaseFilterView.hint

line 253 col 7: This class (or a class which this class inherits from) is marked as '@immutable', but one or more of its instance fields are not final: DateTextField.key, DateTextField.controller, DateTextField.focusNode, DateTextField.decoration, DateTextField.keyboardType, DateTextField.textInputAction, DateTextField.textCapitalization, DateTextField.style, DateTextField.textAlign, DateTextField.textDirection, DateTextField.autofocus, DateTextField.obscureText, DateTextField.autocorrect, DateTextField.maxLines, DateTextField.maxLength, DateTextField.maxLengthEnforced, DateTextField.onChanged, DateTextField.onEditingComplete, DateTextField.onSubmitted, DateTextField.inputFormatters, DateTextField.enabled, DateTextField.cursorWidth, DateTextField.cursorRadius, DateTextField.cursorColor, DateTextField.keyboardAppearance, DateTextField.scrollPadding, DateTextField.enableInteractiveSelection, DateTextField.onTap, DateTextField.clearButtonAction, DateTextField.clearButtonColor, DateTextField.clearButtonIcon, DateTextField.dateTimePickerMode, DateTextField.dateFormat, DateTextField.defaultDate, DateTextField.onDateTimeSelected, DateTextField.textController

Fix lib/src/widgets/base_filter_view.dart. (-0.50 points)

Analysis of lib/src/widgets/base_filter_view.dart reported 1 hint:

line 4 col 16: This class (or a class which this class inherits from) is marked as '@immutable', but one or more of its instance fields are not final: BaseFilterView.filterController, BaseFilterView.hint

Fix lib/src/widgets/bool_filter_view.dart. (-0.50 points)

Analysis of lib/src/widgets/bool_filter_view.dart reported 1 hint:

line 5 col 7: This class (or a class which this class inherits from) is marked as '@immutable', but one or more of its instance fields are not final: BoolFilterView.textUnspecified, BoolFilterView.textTrue, BoolFilterView.textFalse, BaseFilterView.filterController, BaseFilterView.hint

Fix additional 36 files with analysis or formatting issues. (-2 points)

Additional issues in the following files:

  • lib/src/widgets/enum_filter_view.dart (1 hint)
  • lib/src/widgets/number_filter_view.dart (1 hint)
  • lib/src/widgets/sort_view.dart (1 hint)
  • lib/src/widgets/text_filter_view.dart (1 hint)
  • lib/adeptarch.dart (Run flutter format to format lib/adeptarch.dart.)
  • lib/src/api/adept_chopper_client.dart (Run flutter format to format lib/src/api/adept_chopper_client.dart.)
  • lib/src/api/api_service.dart (Run flutter format to format lib/src/api/api_service.dart.)
  • lib/src/api/backend_api.dart (Run flutter format to format lib/src/api/backend_api.dart.)
  • lib/src/dao/filters_dao.dart (Run flutter format to format lib/src/dao/filters_dao.dart.)
  • lib/src/dao/super_dao.dart (Run flutter format to format lib/src/dao/super_dao.dart.)
  • lib/src/dao/super_room.dart (Run flutter format to format lib/src/dao/super_room.dart.)
  • lib/src/filters/bool_filter.dart (Run flutter format to format lib/src/filters/bool_filter.dart.)
  • lib/src/filters/date_filter.dart (Run flutter format to format lib/src/filters/date_filter.dart.)
  • lib/src/filters/enum_filter.dart (Run flutter format to format lib/src/filters/enum_filter.dart.)
  • lib/src/filters/filter.dart (Run flutter format to format lib/src/filters/filter.dart.)
  • lib/src/filters/filter_controller.dart (Run flutter format to format lib/src/filters/filter_controller.dart.)
  • lib/src/filters/filters.dart (Run flutter format to format lib/src/filters/filters.dart.)
  • lib/src/filters/number_filter.dart (Run flutter format to format lib/src/filters/number_filter.dart.)
  • lib/src/filters/text_filter.dart (Run flutter format to format lib/src/filters/text_filter.dart.)
  • lib/src/interfaces/ifilter.dart (Run flutter format to format lib/src/interfaces/ifilter.dart.)
  • lib/src/interfaces/ifilter_list.dart (Run flutter format to format lib/src/interfaces/ifilter_list.dart.)
  • lib/src/pagination/adept_pagination.dart (Run flutter format to format lib/src/pagination/adept_pagination.dart.)
  • lib/src/pagination/flutter_pagewise.dart (Run flutter format to format lib/src/pagination/flutter_pagewise.dart.)
  • lib/src/pagination/request_paginate.dart (Run flutter format to format lib/src/pagination/request_paginate.dart.)
  • lib/src/repository/filters_repository.dart (Run flutter format to format lib/src/repository/filters_repository.dart.)
  • lib/src/repository/super_repository.dart (Run flutter format to format lib/src/repository/super_repository.dart.)
  • lib/src/resource/resource.dart (Run flutter format to format lib/src/resource/resource.dart.)
  • lib/src/resource/resource_data_access.dart (Run flutter format to format lib/src/resource/resource_data_access.dart.)
  • lib/src/resource/resource_loader.dart (Run flutter format to format lib/src/resource/resource_loader.dart.)
  • lib/src/resource/resource_status.dart (Run flutter format to format lib/src/resource/resource_status.dart.)
  • lib/src/utils/adept_publish_subject.dart (Run flutter format to format lib/src/utils/adept_publish_subject.dart.)
  • lib/src/utils/observer.dart (Run flutter format to format lib/src/utils/observer.dart.)
  • lib/src/utils/sort_mode.dart (Run flutter format to format lib/src/utils/sort_mode.dart.)
  • lib/src/viewmodel/filters_viewmodel.dart (Run flutter format to format lib/src/viewmodel/filters_viewmodel.dart.)
  • lib/src/viewmodel/super_view_model.dart (Run flutter format to format lib/src/viewmodel/super_view_model.dart.)
  • lib/src/widgets/widgets.dart (Run flutter format to format lib/src/widgets/widgets.dart.)

Maintenance issues and suggestions

Homepage URL isn't helpful. (-10 points)

Update the homepage field from pubspec.yaml: link to a website about the package or use the source repository URL.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and adeptarch.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
adeptasync ^1.0.1+2 1.0.1+2
adeptutils ^1.0.5+10 1.0.5+10
chopper ^3.0.1+1 3.0.1+1
floor ^0.11.0 0.11.0
flutter 0.0.0
flutter_pagewise ^1.2.3 1.2.3
http ^0.12.0+4 0.12.0+4
intl ^0.16.0 0.16.1
json_annotation ^3.0.1 3.0.1
rxdart ^0.23.1 0.23.1
Transitive dependencies
async 2.4.0
charcode 1.1.3
collection 1.14.11 1.14.12
date_format 1.0.8
device_info 0.4.1+5
floor_annotation 0.6.0
flutter_web_plugins 0.0.0
fluttertoast 3.1.3
http_parser 3.1.3
logging 0.11.4
meta 1.1.8
modal_progress_hud 0.1.3
package_info 0.4.0+14
path 1.6.4
pedantic 1.9.0
plugin_platform_interface 1.0.2
shared_preferences 0.5.6+2
shared_preferences_macos 0.0.1+6
shared_preferences_platform_interface 1.0.3
shared_preferences_web 0.1.2+4
sky_engine 0.0.99
source_span 1.6.0
sqflite 1.2.1
string_scanner 1.0.5
synchronized 2.2.0
term_glyph 1.1.0
typed_data 1.1.6
url_launcher 5.4.2
url_launcher_macos 0.0.1+4
url_launcher_platform_interface 1.0.6
url_launcher_web 0.1.1+1
vector_math 2.0.8
Dev dependencies
build_runner ^1.7.4
chopper_generator ^3.0.0
floor_generator ^0.11.0
flutter_test
json_serializable ^3.2.5