adaptive_widgets 0.0.4

  • Readme
  • Changelog
  • Example
  • Installing
  • 67

adaptive_widgets #

A set of utilities which allow you to dynamically adapt your app to the current platform.

Installing #

Simply add the dependency to your project's pubspec.yaml file:

adaptive_widgets: ^0.0.4

Usage #

Adaptive Widget #

You can use the AdaptiveWidget class to allow your app to choose between two different widgets depending on platform:

AdaptiveWidget(
  cupertinoBuilder: (_) => CupertinoSlider(
    onChanged: _valueChanged,
    value: _value,
  ),
  materialBuilder: (_) => Slider(
    onChanged: _valueChanged,
    value: _value,
  ),
);

Adaptive Route #

The createAdaptiveRoute method returns either a MaterialPageRoute or a CupertinoPageRoute depending on the platform:

createAdaptiveRoute(
  builder: (_) => MyNiceWidget(),
  title: "My Nice Page",
);

Adaptive App #

The AdaptiveApp class will build either a MaterialApp or a CupertinoApp depending on the platform.

It supports all the properties available in the Material and Cupertino app classes, except that rather than specifying one theme, you can specify a cupertinoTheme, materialTheme, and materialDarkTheme.

AdaptiveApp(
  title: 'My Adaptive App',
  home: HomeWidget(),
  cupertinoTheme: CupertinoThemeData(),
  materialTheme: ThemeData.light(),
  materialDarkTheme: ThemeData.dark(),
);

0.0.4 #

  • Support dark mode for Cupertino themes

0.0.3 #

  • Update docs and examples

0.0.1 #

  • Initial release

example/lib/main.dart

import 'package:adaptive_widgets/adaptive_widgets.dart';
import 'package:flutter/cupertino.dart';
import 'package:flutter/material.dart';

import 'home/home_widget.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  // This widget is the root of your application.
  @override
  Widget build(BuildContext context) {
    return AdaptiveApp(
      title: "Adaptive App",
      home: HomeWidget(),
      cupertinoTheme: CupertinoThemeData(
        primaryColor: Colors.red,
        primaryContrastingColor: Colors.blue,
      ),
      materialTheme: ThemeData.light(),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  adaptive_widgets: ^0.0.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:adaptive_widgets/adaptive_widgets.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
38
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
67
Learn more about scoring.

We analyzed this package on Apr 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test
pedantic ^1.8.0+1