adaptive_navigation 0.0.2
adaptive_navigation: ^0.0.2 copied to clipboard

Flutter Android iOS Linux macOS web Windows

A component to be used in place of the Scaffold widget when you want automatic switching between Navigation Rail and Bottom Navigation Bar.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  adaptive_navigation: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:adaptive_navigation/adaptive_navigation.dart';
9
likes
110
pub points
54%
popularity

Publisher

material.io

A component to be used in place of the Scaffold widget when you want automatic switching between Navigation Rail and Bottom Navigation Bar.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

adaptive_breakpoints, flutter

More

Packages that depend on adaptive_navigation