ad_suyi_flutter_sdk 1.1.7 copy "ad_suyi_flutter_sdk: ^1.1.7" to clipboard
ad_suyi_flutter_sdk: ^1.1.7 copied to clipboard

PlatformiOS

advertising aggregation flitter plug-in. Please check the document for details

4
likes
115/ 140
pub points
30%
popularity

We analyzed this package 4 days ago, and awarded it 115 pub points (of a possible 140):

failed
Follow Dart file conventions
25 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

1 out of 109 API elements (0.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: ad_suyi_ad, ad_suyi_ad.ADSuyiFlutterBannerAd, ad_suyi_ad.ADSuyiFlutterBannerAd.ADSuyiFlutterBannerAd, ad_suyi_ad.ADSuyiFlutterBannerAd.height, ad_suyi_ad.ADSuyiFlutterBannerAd.loadAndShow.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 1 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ iOS

These platforms are not supported:

Package does not support platform `Android`.

Because:

  • package:ad_suyi_flutter_sdk/ad_suyi_flutter_sdk.dart that declares support for platforms: iOS.
Package does not support platform `Windows`.

Because:

  • package:ad_suyi_flutter_sdk/ad_suyi_flutter_sdk.dart that declares support for platforms: iOS.
Package does not support platform `Linux`.

Because:

  • package:ad_suyi_flutter_sdk/ad_suyi_flutter_sdk.dart that declares support for platforms: iOS.
Package does not support platform `macOS`.

Because:

  • package:ad_suyi_flutter_sdk/ad_suyi_flutter_sdk.dart that declares support for platforms: iOS.
Package does not support platform `Web`.

Because:

  • package:ad_suyi_flutter_sdk/ad_suyi_flutter_sdk.dart that declares support for platforms: iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

lib/ad_suyi_ad.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/ad_suyi_flutter_sdk.dart doesn't match the Dart formatter.

To format your files run: dart format .

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

4
likes
115
pub points
30%
popularity

Publisher

verified publisheradmobile.top

advertising aggregation flitter plug-in. Please check the document for details

Homepage

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter

More

Packages that depend on ad_suyi_flutter_sdk