action_broadcast 1.0.0

  • Readme
  • Changelog
  • Installing
  • 40

action_broadcast #

pub package

一个简单的全局广播系统,类似于Android的本地广播

Usage #

Listen #

  • 传统使用方式

 const actionUserLogin = 'actionUserLogin';
 const actionUserInfoChange = 'actionUserInfoChange';
 const actionLogout = 'actionLogout';

 StreamSubscription receiver;

 @override
 void initState() {
    super.initState();

    receiver = registerReceiver(['actionUserLogin','actionUserInfoChange','actionLogout']).listen((intent){
            switch(intent.action){
                case 'actionUserLogin': accountId = intent.data;
                             break;
                case 'actionUserInfoChang': nickname = intent['nickname'];
                             break;
                case 'actionLogout': Navigator.pop(context);
                             break;
            }
    });
 }

 @override
 void dispose(){
   receiver.cancel();
   super.dispose();
 }

  • State中混入自动化管理StreamSubscriptionAutoCancelStreamMixin以简化工作

class _ExampleState extends State<Example> with AutoCancelStreamMixin{

  @override
  Iterable<StreamSubscription> get registerSubscriptions sync* {
    yield registerReceiver([actionExample]).listen((intent) {
        setState(() {
          // do something
        });
      },
    );
  }

}

Notify #

sendBroadcast(actionUserLogin,extras:{'accountId':'adc'});

sendBroadcast(actionUserInfoChang,data:'nickname');

[1.0.0] - 2019/8/20

  • 首次完成提交

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  action_broadcast: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:action_broadcast/action_broadcast.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
40
Learn more about scoring.

We analyzed this package on Oct 11, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/action_broadcast.dart.

Run flutter format to format lib/action_broadcast.dart.

Maintenance issues and suggestions

The description contains too many non-ASCII characters. (-20 points)

The site uses English as its primary language. The value of the description field in your package's pubspec.yaml field should primarily contain characters used in English.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and action_broadcast.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test