accuracy_setting 1.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 67

accuracy_setting #

Get Location Accuracy Setting

Get Accuracy #

AccuracySettingMode mode = await AccuracySetting.getAccuracySetting();
print(mode);

Response #

LOCATION_MODE_OFF,
LOCATION_MODE_SENSORS_ONLY,
LOCATION_MODE_BATTERY_SAVING,
LOCATION_MODE_HIGH_ACCURACY,
NOT_IMPLEMENTED, // if API < 19 or API >= 28

Get Provider Enabled #

return true if enabled

if (await AccuracySetting.getProviderEnabled(LocationProvider.GPS)) {
  print("GPS Active");
}

if (await AccuracySetting.getProviderEnabled(LocationProvider.NETWORK)) {
  print("Network Active");
}

Author #

This plugin for Flutter is developed by Fuad Ar-Radhi.

1.0.0 #

  • Initial relealse
  • getAccuracySetting
  • getProviderEnabled

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:accuracy_setting/accuracy_setting.dart';

void main() {
  runApp(MyApp());
}

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  @override
  void initState() {
    super.initState();
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Plugin example app'),
        ),
        body: Center(
          child: FlatButton(
            child: Text(
              'Get Accuracy Setting',
            ),
            onPressed: () async {
              AccuracySettingMode mode =
                  await AccuracySetting.getAccuracySetting();
              print(mode);

              if (await AccuracySetting.getProviderEnabled(
                  LocationProvider.GPS)) {
                print("GPS Active");
              }

              if (await AccuracySetting.getProviderEnabled(
                  LocationProvider.NETWORK)) {
                print("Network Active");
              }
            },
          ),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  accuracy_setting: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:accuracy_setting/accuracy_setting.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
34
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
67
Learn more about scoring.

We analyzed this package on Jul 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because:

  • package:accuracy_setting/accuracy_setting.dart that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because:

  • package:accuracy_setting/accuracy_setting.dart that declares support for platforms: android, ios

Package does not support Flutter platform web

Because:

  • package:accuracy_setting/accuracy_setting.dart that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because:

  • package:accuracy_setting/accuracy_setting.dart that declares support for platforms: android, ios

Package not compatible with SDK dart

Because:

  • accuracy_setting that is a package requiring null.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test