account_cmd_parser 1.0.0 copy "account_cmd_parser: ^1.0.0" to clipboard
account_cmd_parser: ^1.0.0 copied to clipboard

A wrapper of ArgParser to parse command-line arguments or console inputs to a predefined Account model.

0
likes
140/ 140
pub points
0%
popularity

We analyzed this package 41 hours ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

3 out of 13 API elements (23.1 %) have documentation comments.

Some symbols that are missing documentation: account_cmd_parser, account_cmd_parser.Account, account_cmd_parser.Account.Account, account_cmd_parser.Account.email, account_cmd_parser.Account.empty.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:account_cmd_parser/account_cmd_parser.dart that imports:
  • package:account_cmd_parser/src/account_arg_parser.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
args ^2.4.0 2.5.0 2.5.0
equatable ^2.0.5 2.0.5 2.0.5
Transitive dependencies
Package Constraint Compatible Latest
collection - 1.18.0 1.18.0
meta - 1.14.0 1.14.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Dart 3.3.3.

Check the analysis log for details.

0
likes
140
pub points
0%
popularity

Publisher

verified publishermintminter.dev

A wrapper of ArgParser to parse command-line arguments or console inputs to a predefined Account model.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

args, equatable

More

Packages that depend on account_cmd_parser