access 1.5.0+1

Dart native
Flutter Android iOS

A simple database utility for the entity library and PostgreSQL.

0
likes
75 / 110
pub points
61 %
popularity

We analyzed this package on Oct 30, 2020, and awarded it 75 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:4:5

  ╷
4 │ <li><a href="http://www.dartdocs.org/documentation/access/1.5.0">API Reference</a></li>
  │     ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 68 out of 128 API elements (53.1 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:access/access.dart that imports:
  • package:entity/postgresql2.dart that imports:
  • package:postgresql2/postgresql.dart that imports:
  • package:postgresql2/src/postgresql_impl/postgresql_impl.dart that imports:
  • package:postgresql2/constants.dart that imports:
  • package:postgresql2/pool.dart that imports:
  • package:postgresql2/src/pool_impl.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 120 issues. Showing the first 2:

INFO: Avoid const keyword.

lib/access.dart:46:17

   ╷
46 │ const notNull = const Not(null);
   │                 ^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/access.dart

INFO: Don't type annotate initializing formals.

lib/access.dart:61:13

   ╷
61 │   const Not(T this.value);
   │             ^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/access.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
entity>=0.7.01.9.0+11.9.0+1
logging>=0.11.0 <2.0.00.11.40.11.4
postgresql2>=0.5.00.5.8+10.5.8+1
rikulo_commons>=3.0.04.2.14.2.1
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.1.31.1.3
collection-1.14.131.14.13
convert-2.1.12.1.1
crypto-2.1.52.1.5
mime-0.9.70.9.7
typed_data-1.2.01.2.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0
likes
75
pub points
61%
popularity

A simple database utility for the entity library and PostgreSQL.

Repository (GitHub)
View/report issues

Documentation

Documentation
API reference

Uploader

tomyeh@rikulo.org

License

Apache 2.0 (LICENSE)

Dependencies

entity, logging, postgresql2, rikulo_commons

More

Packages that depend on access