abstract_dart 1.0.2
abstract_dart: ^1.0.2 copied to clipboard

A collection of algebraic structures borrowed from abstract algebra. Semigroup, Monoid, Group & Field.

2
likes
90 / 110
pub points
46 %
popularity

We analyzed this package on Apr 13, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 9 out of 126 API elements (7.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
decimal^0.3.50.3.51.0.0+1
Transitive dependencies
PackageConstraintCompatibleLatest
rational-0.3.81.0.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.3.5` on decimal does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions decimal to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.

2
likes
90
pub points
46%
popularity

Publisher

modulovalue.com

A collection of algebraic structures borrowed from abstract algebra. Semigroup, Monoid, Group & Field.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

decimal

More

Packages that depend on abstract_dart