ably_flutter 1.2.33 copy "ably_flutter: ^1.2.33" to clipboard
ably_flutter: ^1.2.33 copied to clipboard

A wrapper around Ably's Cocoa and Java client library SDKs, providing iOS and Android support.

38
likes
150/ 160
pub points
91%
popularity

We analyzed this package 6 days ago, and awarded it 150 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

399 out of 400 API elements (99.8 %) have documentation comments.

Some symbols that are missing documentation: ably_flutter.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:ably_flutter/ably_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:ably_flutter/ably_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:ably_flutter/ably_flutter.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:ably_flutter/ably_flutter.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 26 issues. Showing the first 2:

INFO: The referenced identifier is a wildcard.

bin/templates/platformconstants.dart.dart:7:47

  ╷
7 │ ${c['types'].map((_) => "  static const int ${_['name']} ="
  │                                               ^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze bin/templates/platformconstants.dart.dart

INFO: The referenced identifier is a wildcard.

bin/templates/platformconstants.dart.dart:8:13

  ╷
8 │         " ${_['value']};").join('\n')}
  │             ^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze bin/templates/platformconstants.dart.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
collection ^1.15.0 1.18.0 1.19.0
flutter flutter 0.0.0 0.0.0
meta ^1.3.0 1.12.0 1.15.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
material_color_utilities - 0.8.0 0.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.8, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

38
likes
150
pub points
91%
popularity

Publisher

verified publisherably.com

A wrapper around Ably's Cocoa and Java client library SDKs, providing iOS and Android support.

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

Apache-2.0 (license)

Dependencies

collection, flutter, meta

More

Packages that depend on ably_flutter