a01r066 0.0.2 copy "a01r066: ^0.0.2" to clipboard
a01r066: ^0.0.2 copied to clipboard

Fancy pre-built flutter plugin that can easily be integrated into any Flutter application.

2
likes
130/ 160
pub points
0%
popularity

We analyzed this package 2 days ago, and awarded it 130 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

6 out of 158 API elements (3.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: a01r066, a01r066.A01r066, a01r066.A01r066.A01r066, a01r066.A01r066.getPlatformVersion, a01r066.AfterFirstFrameMixin.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:a01r066/a01r066.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:a01r066/a01r066.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:a01r066/a01r066.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:a01r066/a01r066.dart that declares support for platforms: Android, iOS.
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 17 issues. Showing the first 2:

INFO: 'window' is deprecated and shouldn't be used. Look up the current FlutterView from the context via View.of(context) or consult the PlatformDispatcher directly instead. Deprecated to prepare for the upcoming multi-window support. This feature was deprecated after v3.7.0-32.0.pre.

lib/src/common/values/device_types.dart:6:39

  ╷
6 │   static double devicePixelRatio = ui.window.devicePixelRatio;
  │                                       ^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/common/values/device_types.dart

INFO: 'window' is deprecated and shouldn't be used. Look up the current FlutterView from the context via View.of(context) or consult the PlatformDispatcher directly instead. Deprecated to prepare for the upcoming multi-window support. This feature was deprecated after v3.7.0-32.0.pre.

lib/src/common/values/device_types.dart:7:28

  ╷
7 │   static ui.Size size = ui.window.physicalSize;
  │                            ^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/common/values/device_types.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
intl ^0.17.0 0.17.0 0.19.0
plugin_platform_interface ^2.0.2 2.1.8 2.1.8
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.17.0` on intl does not support the stable version `0.18.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

2
likes
130
pub points
0%
popularity

Publisher

unverified uploader

Fancy pre-built flutter plugin that can easily be integrated into any Flutter application.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter, intl, plugin_platform_interface

More

Packages that depend on a01r066