_firebase_database_collection_vm 0.0.2

  • Readme
  • Changelog
  • Installing
  • new53

firebase_database_collection_vm #

A package used by Firestore and Realtime Database packages. This package is not intended to be consumed directly.

Features and bugs #

Please file feature requests and bugs at the issue tracker.

0.0.2 #

  • Update README
  • Fixed analyzer warnings

0.0.1 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  _firebase_database_collection_vm: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:_firebase_database_collection_vm/_firebase_database_collection_vm.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
14
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
53
Learn more about scoring.

We analyzed this package on Mar 30, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6

Health suggestions

Format lib/src/array_sorted_map.dart.

Run dartfmt to format lib/src/array_sorted_map.dart.

Format lib/src/immutable_sorted_map.dart.

Run dartfmt to format lib/src/immutable_sorted_map.dart.

Format lib/src/immutable_sorted_map_iterator.dart.

Run dartfmt to format lib/src/immutable_sorted_map_iterator.dart.

Fix additional 7 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/immutable_sorted_set.dart (Run dartfmt to format lib/src/immutable_sorted_set.dart.)
  • lib/src/llrb_black_value_node.dart (Run dartfmt to format lib/src/llrb_black_value_node.dart.)
  • lib/src/llrb_empty_node.dart (Run dartfmt to format lib/src/llrb_empty_node.dart.)
  • lib/src/llrb_node.dart (Run dartfmt to format lib/src/llrb_node.dart.)
  • lib/src/llrb_red_value_node.dart (Run dartfmt to format lib/src/llrb_red_value_node.dart.)
  • lib/src/lltb_value_node.dart (Run dartfmt to format lib/src/lltb_value_node.dart.)
  • lib/src/rb_tree_sorted_map.dart (Run dartfmt to format lib/src/rb_tree_sorted_map.dart.)

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and _firebase_database_collection_vm.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
Dev dependencies
dart_quickcheck
test ^1.6.8