zoned_date 1.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 0

zoned_date #

DateTime with timezones.

Usage #

Create #

Interpret DateTime as different zone #

Interpret year, month, day, hour, minute, second, millisecond and microsecond with different time zone.

// Interpret 2018.1.14T17:32 in EST timezone
final time = new ZonedDate.asZone(new DateTime(2018, 1, 14, 17, 32), Timezone.est);

Convert to different zone #

// Convert local current time to EST
final time = new ZonedDate.convertZone(new, Timezone.est);

Current time at different timezone #

// Convert local current time to EST
final time = new ZonedDate(Timezone.est);

Changelog #

1.0.0 #

  • ZonedDate


import 'package:zoned_date/zoned_date.dart';

main() {
  print(new ZonedDate.convertZone(new, Timezone.est));
  print(new ZonedDate(Timezone.est));
  print(new ZonedDate());

  final time = new ZonedDate.make(2018,
      month: 1, day: 14, hour: 1, minute: 15, zone: Timezone.est);
  print(time.add(new Duration(hours: 1)));

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  zoned_date: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:zoned_date/zoned_date.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0