zone_di 1.0.0
zone_di: ^1.0.0

Dart native js
Flutter Android iOS web

Dependency injection with a functional API that works without code generation, mirrors or passing around Injector objects.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

dependencies:
  zone_di: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:zone_di/zone_di.dart';
0
likes
100
pub points
0%
popularity

Dependency injection with a functional API that works without code generation, mirrors or passing around Injector objects.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

philippschiffmann93@gmail.com

License

MIT (LICENSE)

Dependencies

meta

More

Packages that depend on zone_di