zo_appbar 0.0.5

  • Readme
  • Changelog
  • Example
  • Installing
  • 58

Build Status

zo_appbar #

an appbar for the zoworld (zoworld is an upcoming collection of apps developed by me)

About #

This is an appbar designed by me for an upcoming project which I have codenamed "zo". Please feel free to utilize it for your own projects too.

Screenshot #

You will find a screenshot depicting zo_appbar, here.

[0.0.5] - 09/24/2019

  • Updated the README as it wasn't correctly displaying the screenshot on pub.dev.

[0.0.4] - 09/24/2019

  • Added a proper example app.
  • Added a screenshot in the README.
  • Rewrote tests.
  • Builds are now passing!

[0.0.3] - 09/21/2019

  • Updated the description for an improved pub score

[0.0.2] - 09/20/2019

  • Updated the README, builds are still failing.

[0.0.1] - 09/20/2019

  • Initial release: This is an appbar designed by me for an upcoming project which I have codenamed "zo". Please feel free to utilize it for your own projects too.

example/README.md

an example app which demonstrates zo_appbar

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  zo_appbar: ^0.0.5

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:zo_appbar/zo_appbar.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
21
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
58
Learn more about scoring.

We analyzed this package on Dec 9, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test