yudiz_modal_sheet 0.0.3

A modal sheet that can also be shown from top of the screen. Advantages over the original modal sheet:

  • It respects the setState()
  • It intercepts touch events and does not dismisses

Usage #

To use this package, use the following dependency :

   dependencies:
     flutter:
       sdk: flutter
     yudiz_modal_sheet:

How to use #

YudizModalSheet.show(
    context: context,
    child: Container(
      color: Colors.white,
      height: 250,
      child: Center(
        child: Text("Hello from top"),
      ),
    ),
    direction: YudizModalSheetDirection.TOP);

Screenshots #

Getting Started #

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

[0.0.1] - TODO: Add release date.

  • A customised and modified modal sheet that can also be displayed from top of the screen

[0.0.3] - TODO: Add release date.

  • Added a parameter to customise background color of the modal sheet

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  yudiz_modal_sheet: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:yudiz_modal_sheet/yudiz_modal_sheet.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
52
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
89
Overall:
Weighted score of the above. [more]
74
Learn more about scoring.

We analyzed this package on Sep 13, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The package description is too short. (-1 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and yudiz_modal_sheet.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test