import "package:youtube_parser/youtube_parser.dart"; String foo = getIdFromUrl("https://www.youtube.com/watch?v=CBWlfU_na-2"); // returns "CBWlfU_na-2" String bar = getIdFromUrl("https://www.notyoutube.com/watch?v=CBWlfU_na-2"); // returns null
This project is licensed under the MIT License - see the LICENSE file for details
Add this to your package's pubspec.yaml file:
dependencies: youtube_parser: ^0.9.3
You can install packages from the command line:
$ pub get
$ flutter pub get
Alternatively, your editor might support
pub get or
flutter pub get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Aug 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Detected platforms: Flutter, web, other
No platform restriction found in primary library
Document public APIs. (-1 points)
2 out of 2 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.
lib/youtube_parser.dart. (-1.99 points)
lib/youtube_parser.dart reported 4 hints:
line 3 col 21: Use isEmpty instead of length
line 4 col 5: DO use curly braces for all flow control structures.
line 7 col 5: DO use curly braces for all flow control structures.
line 12 col 7: DO use curly braces for all flow control structures.
The package description is too short. (-17 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package.
Common filename patterns include
youtube_parser.dart. Packages with multiple examples should provide
For more information see the pub package layout conventions.
Package is getting outdated. (-6.03 points)
The package was last published 55 weeks ago.
|Dart SDK||>=1.12.0 <3.0.0|